Gas pedal broke in the Bay Area - E46Fanatics E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Go Back   E46Fanatics > BMW Regional Forums > Regional Forums > California

California
Have you seen another BMW while driving around in your area? Maybe you can find their car in the E46Fanatics Garage!
Northern California Southern California

If you don't have your garage setup, sign up today HERE

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 03-30-2018, 10:23 AM   #1
eben2rah
Registered User
 
Join Date: Jul 2012
Location: Las Vegas
Posts: 63
My Ride: 2005 325i
Gas pedal broke in the Bay Area

Currently stuck on Highway 12, halfway between Fairfield and Stockton on the way home to Vegas. Waiting for a tow to take me to Valley BMW in Modesto for a new pedal.

This is a long shot, but any chance anyone have an extra drive by wire accelerator pedal that's in the area?

Sent from my [device_name] using E46Fanatics mobile app
__________________
eben2rah is offline   Reply With Quote
Old 03-30-2018, 12:05 PM   #2
eben2rah
Registered User
 
Join Date: Jul 2012
Location: Las Vegas
Posts: 63
My Ride: 2005 325i
Also, has this happened to anybody recently? Seems like a huge safety issue from a poor design

Sent from my [device_name] using E46Fanatics mobile app
__________________
eben2rah is offline   Reply With Quote
Old 03-30-2018, 12:07 PM   #3
eben2rah
Registered User
 
Join Date: Jul 2012
Location: Las Vegas
Posts: 63
My Ride: 2005 325i
Just made it to Valley BMW in Modesto. Has this happened to anybody recently? Seems like a huge safety issue from a poor design

Sent from my [device_name] using E46Fanatics mobile app
__________________
eben2rah is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-30-2018, 12:38 PM   #4
HayWagon
Registered User
 
Join Date: Jun 2017
Location: Collingwood Ontario
Posts: 1,192
My Ride: 03 325iT
Quote:
Originally Posted by eben2rah View Post
Just made it to Valley BMW in Modesto. Has this happened to anybody recently? Seems like a huge safety issue from a poor design

Sent from my [device_name] using E46Fanatics mobile app
Accelerator pedal malfunctions are fairly rare.

Sent from my tractor.
HayWagon is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON



All times are GMT -5. The time now is 09:59 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
(c) 1999 - VerticalScope Inc. All rights reserved.