door locks are crazy - E46Fanatics E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rating: Thread Rating: 51 votes, 4.94 average. Display Modes
Old 09-23-2003, 09:10 PM   #1
MIAMITOPAZ
Registered User
 
Join Date: Aug 2003
Location: VICE CITY
Posts: 1,117
My Ride: Rieger323CI
Send a message via Yahoo to MIAMITOPAZ
door locks are crazy

I've had this problem for over a year now and i cant take it anymore.

when i walk up to my car and remote unlock it i hear a click but nothing opens... ok i use the key i get in no problem. I go to open the passenger door, i pull the handle nothing happens. I push the unlock button, click, click and nothin happens. If a passenger wants to get in... guess what, they have to jump over my seat to get.

This problem happens to me about 50/50 of time i use my car and its getting to be really annoying.

I take it to the dealer and they work fine-- they think im crazy-
someone told me it might be the accuators and that if one is bad it fools the other one, is that true?i've noticed the car thinks that i have open it so my gas tank stays lock and i have to use the emergency release in the trunk too--this sux

Has anyone else had this problem and fixed it?
__________________

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
MIAMITOPAZ is offline   Reply With Quote
Old 09-24-2003, 08:52 AM   #2
MIAMITOPAZ
Registered User
 
Join Date: Aug 2003
Location: VICE CITY
Posts: 1,117
My Ride: Rieger323CI
Send a message via Yahoo to MIAMITOPAZ
i had to re-phrase what i wrote yesterday

i meant to say when i press the unlock, the car clicks but the actual locks dont release including the gas door, meaning the car thinks i havent unlocked it yet.

could it be 1 main trigger in the car is keeping the whole car from unlocking?
could it be that its stuck, or its defective, remember this happens to me half the time. so if something is broken shouldnt it stay broken and not just work when ever it feels like it?

i dont know what that bad part could be

help plz
__________________

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
MIAMITOPAZ is offline   Reply With Quote
Old 09-24-2003, 08:54 AM   #3
Tommy_hf
Registered User
 
Join Date: May 2003
Location: Netherlands
Posts: 1,227
My Ride: '03 ci
miamitopaz,
I have the same problem, but just a bit less often than you. I took it to the dealer and they found the central locking computer at fault. It sent varying voltages to the doorlocks, sometimes too little , causing the doors to stay shut whil you can hear a click.
It's an expensive sucker though... 350-400 bucks.
__________________

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
Tommy_hf is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-11-2008, 03:26 PM   #4
justanotherokie
Registered User
 
Join Date: Apr 2008
Location: Broken Arrow, OK
Posts: 47
My Ride: 2002 330i
I have exactly the same symptom.

My Driver door would unlock but not the passenger. Then the driver door quit. I heard it try to unlock but it wasn't sending enough juice to do the job.

The button inside worked fine. Now both keys work fine. Maybe the button reset it?

Gremlins...
justanotherokie is offline   Reply With Quote
Old 09-25-2003, 08:51 AM   #5
KevinJ_2k1_325ci
Registered User
 
Join Date: Dec 1969
Location: Alexandria, VA
Posts: 3,092
My Ride: 2001 325ci
yeah expensive which means it will be hard to get replaced.

If you have a responsible service department who cares about your safety and the possibility of god forbid you getting in an accident and getting locked in your car, then they will replace it. If you have a greedy one who looks out for the BMW bonus for not repairing items under warranty, you have a uphil battle.


Quote:
Originally posted by Tommy_hf
miamitopaz,
I have the same problem, but just a bit less often than you. I took it to the dealer and they found the central locking computer at fault. It sent varying voltages to the doorlocks, sometimes too little , causing the doors to stay shut whil you can hear a click.
It's an expensive sucker though... 350-400 bucks.
KevinJ_2k1_325ci is offline   Reply With Quote
Old 09-25-2003, 09:29 AM   #6
MIAMITOPAZ
Registered User
 
Join Date: Aug 2003
Location: VICE CITY
Posts: 1,117
My Ride: Rieger323CI
Send a message via Yahoo to MIAMITOPAZ
Unfortunatly i've been out of warranty for some time. i took the extended warranty at the dealer (which has never covered anything btw) its not bmws'.

questions is = I've been reprting this problem since i had warranty but they never figured out what is was, since they have the complain in record does that help me in any way?

or the complain doesnt hold anything once the (original)warranty is over?

-----------------------------------------------
if someone doenst pick up this question on this thread i'll probably post this ques. on a new one - sounds like someone might have been thru this kind of warrant issue before.

help me if you know anything-- thanx
__________________

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
MIAMITOPAZ is offline   Reply With Quote
Old 09-25-2003, 11:37 AM   #7
bobm3
Senior Eurowerkz Member
 
bobm3's Avatar
 
Join Date: Jun 2002
Location: bklyn
Posts: 13,189
My Ride: 2003m3smg
you should go back to the dealer and

tell them about the central locking system is out of wack. say
you have been in while you were under warrenty. that they didn't look into this possiablity. see if they will check it out for you. give your car advisor a 10.00 spot. that makes very thing work smooter. see what they say can't hurt to try.
bobm3
__________________

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
bobm3 is offline   Reply With Quote
Old 08-06-2012, 02:01 AM   #8
xcar360
Past Site Sponsor
 
Join Date: Jul 2012
Location: China
Posts: 350
My Ride: BMW 318i
Quote:
Originally Posted by bobm3 View Post
tell them about the central locking system is out of wack. say
you have been in while you were under warrenty. that they didn't look into this possiablity. see if they will check it out for you. give your car advisor a 10.00 spot. that makes very thing work smooter. see what they say can't hurt to try.
bobm3
Wow, sexy
xcar360 is offline   Reply With Quote
Old 08-06-2012, 06:35 AM   #9
jfoj
OEM ///Member
 
Join Date: Nov 2009
Location: Fairfax, VA USA
Posts: 28,904
My Ride: 330CiC, M5, X5, E93
csracing87,

Your problems almost sounds like a bad battery? Similar issues happened in my 2006 vert when the battery had a bad cell.

If the windows auto up at all, your windows probably do not need to be reinitialized and I would doubt you have problems with your window regulators.

Be careful if you have your codes read with a tool that will show body codes as you may have errors for your window regulators that are actually red herrings. I was told both of my window motors needed to be replaced by the dealer and it was only because the windows motors were not initialized after the dealer replaced the battery. If the windows are not initialized, they will show faults that will lead an inexperienced person to think the window regulator(s) are bad.

As for reinitializing the windows, the Vert is VERY different and even the procedure documented in the Bentley manual misses a vital step and is a bit misleading. Search my signature and you should find the procedure for window initialization, you actually have to bring each window up and down 2 times, not once, during the procedure.

Also not sure about the GM5 in your car being different, I assume Scott understands that the 2005 3 series coupe and convertible are still an E46? Maybe there is some difference? Many people do not realize that the sedans and wagons transitioned from E45 to the E9x in 2006, however, the coupes and convertibles did not transition to the E9x until 2007.

I have had all kinds of issues getting parts for my 2006 Vert as even the dealers at times assume the car is a E9x!
__________________
Solve your misfires, lean codes, rough idle -
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


Fuel pump failures -
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


Temp Info -
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


Hidden OBC Menu - Check Voltage, Temp, Fuel Level -
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


E46/E39 GM5 Door Lock Info -
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


Lower hose temp switch O-ring - BMW #13621743299

Last edited by jfoj; 08-06-2012 at 06:38 AM.
jfoj is offline   Reply With Quote
Old 09-25-2003, 11:43 AM   #10
gmhl10
Resident CF Whore
 
Join Date: Mar 2003
Location: Honolulu, HI
Posts: 2,889
My Ride: '05 A08 M3
Send a message via AIM to gmhl10 Send a message via MSN to gmhl10
Damn...
I got my 2002 325i brand new from the dealer and I have this problem too!
I'm afraid that if I take my car in about it, they will blame my aftermarket alarm system on the electrical problem.
However, my friend has the same problem on his 2002 325i, and he has all the OEM electronic equipment...
Maybe we should go together one day. :tongue:
__________________
'05 Silbergrau M3 - mfg date: May '05
Modifications: WAY too much to list


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
gmhl10 is offline   Reply With Quote
Old 09-30-2003, 11:33 AM   #11
BMWNA
BMW NA Customer Relations
 
Join Date: Dec 1969
Location: NJ
Posts: 111
My Ride: BMW
I'm with BMW of North America, LLC. I've passed this message on to a BMW NA National Customer Relations Representative who will be in touch with you soon, or if you prefer, you can call us at 800-831-1117.

BMW NA Customer Relations
BMWNA is offline   Reply With Quote
Old 01-21-2011, 10:05 PM   #12
bmwguyNC
Registered User
 
Join Date: Jul 2006
Location: Greenville, NC
Posts: 395
My Ride: 02 325i/06 330i e90
Send a message via AIM to bmwguyNC
Quote:
Originally Posted by BMWNA View Post
I'm with BMW of North America, LLC. I've passed this message on to a BMW NA National Customer Relations Representative who will be in touch with you soon, or if you prefer, you can call us at 800-831-1117.

BMW NA Customer Relations
WOW! Great customer service actually someone on the forum from BMWNA! Way to help us out man!
bmwguyNC is offline   Reply With Quote
Old 02-25-2011, 12:21 PM   #13
TopazBlu02
Registered User
 
Join Date: Oct 2010
Location: Portland, OR
Posts: 395
My Ride: 330CI
Last month, my passenger door wouldn't unlock with the key or center console button for a few days. Then out of nowhere, it went away and has worked fine since.

Then last week, my check engince light came on and the car was shaking/rumbling. I shut it off and waited a few minutes and turned it on. Light went away and runs fine. Old cars are gonna have issues like these, and thank god mines fixed itself.
TopazBlu02 is offline   Reply With Quote
Old 02-26-2011, 08:40 PM   #14
islanq
Registered User
 
Join Date: Jul 2006
Location: Lincoln, CA
Posts: 624
My Ride: An E46 like you...
Send a message via AIM to islanq
Quote:
Originally Posted by TopazBlu02 View Post
Last month, my passenger door wouldn't unlock with the key or center console button for a few days. Then out of nowhere, it went away and has worked fine since.

Then last week, my check engince light came on and the car was shaking/rumbling. I shut it off and waited a few minutes and turned it on. Light went away and runs fine. Old cars are gonna have issues like these, and thank god mines fixed itself.
Yours work fine now because you live in Portland (my home town of 18 years) and it's cold this time of year. Address your GM5 now before the weather heats up. If you car is shaking in the cold try cleaning your MAF, checking all your hoses for a vacuum leak, clean ICV and DISA valve. If that doesn't fix it your next step is changing the Pre-Cat 02 sensor. (which acts up in the cold quite often).

PS. Not to be a dick, but be smart.... Cars do not fix themselves....

Last edited by islanq; 02-26-2011 at 08:42 PM.
islanq is offline   Reply With Quote
Old 09-30-2003, 11:58 AM   #15
MIAMITOPAZ
Registered User
 
Join Date: Aug 2003
Location: VICE CITY
Posts: 1,117
My Ride: Rieger323CI
Send a message via Yahoo to MIAMITOPAZ
GREAT
__________________

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
MIAMITOPAZ is offline   Reply With Quote
Old 09-30-2003, 01:42 PM   #16
ADA
 
Join Date: Feb 2003
Posts: 2,591
Man,

I have the same problem. It is not 50/50% though. It is more like 33% of the time. I went to my dealer and told them about the problem and they think I was CRAZY and/or STUPID.

The service rep was trying to show me how to operate the unlock/lock door features on my car and remote. I was mad that they though that I was THAT dumb.

Anyhow, I finally convinced him to take a look at my car. He came back and said, "Sorry nothing on the fault codes and therefore there is not a problem." He said this while implying that the problem was all in my mind. I was mad!!!!


Anyhow, I am glad that I am not the only with this problem
ADA is offline   Reply With Quote
Old 09-30-2003, 02:13 PM   #17
TheRiddle
Sofa-king-what
 
Join Date: Oct 2002
Location: Tuscany & NY
Posts: 1,845
My Ride: M52TUB28-Vert
dude...

we're having the same problem all around the world..


my car too refuse to get opened with remote...(but lock are ok as the alarm)

dealer said (after using with modic) that the problem is the key...(in fact he tried to re-initialize it, but with no succes)

why this is happening ???? i didn't saw any "best before..." in the back of the key....


and I can't give the fault to the b.shop that let the battery out of charge for 2 days.........
TheRiddle is offline   Reply With Quote
Old 09-30-2003, 03:33 PM   #18
JRobUSC
 
Join Date: Dec 1969
Posts: 732
I had that happen to me, dealer replaced the actuators under warranty.

Haven't had the problem since, though the driver side lock sometimes only opens halfway and you have to hit the unlock button again to get it to work. If it keeps up I'll take it back in again.
JRobUSC is offline   Reply With Quote
Old 09-30-2003, 04:22 PM   #19
gokcer
Registered User
 
Join Date: Apr 2003
Location: Philadelphia
Posts: 2,493
My Ride: 323Ci Sports Package
Since I bought my car, I have the same problem and I cant replicate at the dealer it happens in cold days and after car washes that my key will not LOCK the car. The problem is I always have to visually check if doors are locked since there is no visual indication from a distance.

Everytime I took it to dealer they cant replicate it and now I am coming to end of my warranty. I am afraid it is gonna go kaput and i am gonna have to pay for it.

A
__________________

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

If you have helpful tips about auto insurance, email me at
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Bright-Red 323ci 5sp. Sports + Premium + Homemade K&N intake box. -->
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Also for single fanatics try My
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

New House Tool
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
gokcer is offline   Reply With Quote
Old 09-30-2003, 04:23 PM   #20
gokcer
Registered User
 
Join Date: Apr 2003
Location: Philadelphia
Posts: 2,493
My Ride: 323Ci Sports Package
Am I crazy or the BMW NA reply is a little weird? How are they gonna get in touch with you, they don't know who you are!
__________________

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

If you have helpful tips about auto insurance, email me at
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Bright-Red 323ci 5sp. Sports + Premium + Homemade K&N intake box. -->
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Also for single fanatics try My
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

New House Tool
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
gokcer is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON



All times are GMT -5. The time now is 08:39 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
(c) 1999 - VerticalScope Inc. All rights reserved.