[MS4X] Siemens MS43 Community Patchlist for Tuner Pro - Page 9 - E46Fanatics E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Go Back   E46Fanatics > Tuning & Tech > Driveline, Engine & DME Tuning

Driveline, Engine & DME Tuning
Talk about driveline improvements, NA tuning and DME tuning your E46 BMW here. This includes diffs, intakes, exhausts, chips, software and OBD tuning.

Reply
 
Thread Tools Search this Thread Rating: Thread Rating: 1 votes, 5.00 average. Display Modes
Old 08-04-2019, 02:22 PM   #161
scorpionreptyle
Registered User
 
Join Date: Sep 2016
Location: Bucharest
Posts: 677
My Ride: e36 330i
Year: 1997
Model: E36
Transmission: 5 spd manual
Quote:
Originally Posted by andyz28 View Post
ok, so the only thing i need to do is flash the file "E46 M54B22 EU4 LHD" to my ecu using the ms4x flasher without patching the ews or checksum bypass? i want the launch control function, so i need to activate the launch control with the patch but without moving nothing more?

thanks you in advance

you apply the needed patch only. Every one is mandatory ,not a must. if your car does not start after ews sync ,then try to use ultimo for correction (against your actual working full file) then flash with superfaster ms4x flasher,but disable chk correction under settings.
__________________

Last edited by scorpionreptyle; 08-04-2019 at 02:24 PM.
scorpionreptyle is offline   Reply With Quote
Old 08-04-2019, 04:47 PM   #162
danius375
Registered User
 
Join Date: Oct 2017
Location: United Kingdom
Posts: 21
My Ride: BMW 330ci (E46)
Quote:
Originally Posted by sda2 View Post
Is there anyone willing to test a new, true Alpha-N patch before we launch it into the patchlist?
More than happy to try it out on a pretty much standard M54B30.
danius375 is offline   Reply With Quote
Old 08-11-2019, 01:50 PM   #163
scorpionreptyle
Registered User
 
Join Date: Sep 2016
Location: Bucharest
Posts: 677
My Ride: e36 330i
Year: 1997
Model: E36
Transmission: 5 spd manual
nothing new here ? hows the testing going ? ignition cut will be ready ,it requires a license ?
__________________
scorpionreptyle is offline   Reply With Quote
Old 08-11-2019, 02:07 PM   #164
CarbonZHP
Because Race...Convertible?
 
CarbonZHP's Avatar
 
Join Date: Jun 2013
Location: EAS
Posts: 2,868
My Ride: goes choo choo
Year: 2004
Model: 330Cic ZHP
Transmission: AT->5MT->6MT
Iíd try but I donít know how to carry over my turbo tune from v56


Sent from my iPhone using Tapatalk
__________________
Turbo Build Thread
Original Car: Silver Grey on Grey, A/T (1 of 186)
As it sits: Silver Grey on Black, M/T (1 of 51)
Instagram: @CarbonZHP
CarbonZHP is offline   Reply With Quote
Old 08-14-2019, 11:10 AM   #165
Skdsh
Registered User
 
Join Date: Aug 2019
Location: Pennsylvania
Posts: 4
My Ride: 330I
Who do I have to give my money for the ignition cut. I am about destroy my harness to install a fuel and spark controller.


Sent from my iPhone using E46Fanatics
Skdsh is offline   Reply With Quote
Old 08-15-2019, 08:19 AM   #166
danius375
Registered User
 
Join Date: Oct 2017
Location: United Kingdom
Posts: 21
My Ride: BMW 330ci (E46)
Quote:
Originally Posted by Skdsh View Post
Who do I have to give my money for the ignition cut. I am about destroy my harness to install a fuel and spark controller.


Sent from my iPhone using E46Fanatics
Same here!
danius375 is offline   Reply With Quote
Old 08-15-2019, 10:27 AM   #167
cwarel
Registered User
 
Join Date: Jun 2015
Location: New York City
Posts: 852
My Ride: 330ci coupe
Quote:
Originally Posted by Skdsh View Post
Who do I have to give my money for the ignition cut. I am about destroy my harness to install a fuel and spark controller.


Sent from my iPhone using E46Fanatics
Just insalled wot box 0 flames , only launch control and no lift shift ( i ahve a turbo )
cwarel is offline   Reply With Quote
Old 08-15-2019, 11:37 PM   #168
Harry_de_best
Registered User
 
Join Date: Aug 2018
Location: Australia
Posts: 17
My Ride: E46 330i
Year: 2002
Model: 330i M Sport
Transmission: Manual 5spd
2002 E46 330i EU here. ECU number 5WK90015

MS430069 RHD EU2 full flash file with Checksum bypass, LC, M3 Cluster, Extended DS2 patches applied results in error 100, car only cranks doesn't start. UIF VIN and ISN have been copied over as well - no difference.

MS430069 RHD EU4 full flash with above patches results in the same, car cranks doesn't start.

Sometimes EWS errors came up, re-synced EWS still same issue. TPS error (112?) comes up even when the checksum bypass is patched (lc_swi_cal_mon_cks = 165).

Various flashing combinations tried:

Checksum corrected via new checksum tool posted in this thread earlier + MS4X flasher v1.02 with checksum correction disabled -> car cranks doesn't start

Verified all full and partial reads - all the patches carried over, but only cranks. I'have tried cranking for an extended time as tried by scorpion, however nothing happens.

Patched full file + MS4X flasher v1.02 with checksum correction enabled -> car cranks doesn't start

MS430069 RHD EU2 full flash file with M3 Cluster, Extended DS2 patches applied starts up fine no problems - flashed normally with MS4X checksum correction enabled. Didn't need to re-sync EWS or patch UIF VIN or ISN.

Hope this helps... LC did work in this car on V56 a while ago.


RE sda2: Happy to test Alpha-n, stock apart from catless headers and exhaust. EU vehicle.

Last edited by Harry_de_best; 08-16-2019 at 12:40 AM. Reason: Alpha N
Harry_de_best is offline   Reply With Quote
Old 08-17-2019, 04:26 PM   #169
scorpionreptyle
Registered User
 
Join Date: Sep 2016
Location: Bucharest
Posts: 677
My Ride: e36 330i
Year: 1997
Model: E36
Transmission: 5 spd manual
Quote:
Originally Posted by Harry_de_best View Post
2002 E46 330i EU here. ECU number 5WK90015

MS430069 RHD EU2 full flash file with Checksum bypass, LC, M3 Cluster, Extended DS2 patches applied results in error 100, car only cranks doesn't start. UIF VIN and ISN have been copied over as well - no difference.

MS430069 RHD EU4 full flash with above patches results in the same, car cranks doesn't start.

Sometimes EWS errors came up, re-synced EWS still same issue. TPS error (112?) comes up even when the checksum bypass is patched (lc_swi_cal_mon_cks = 165).

Various flashing combinations tried:

Checksum corrected via new checksum tool posted in this thread earlier + MS4X flasher v1.02 with checksum correction disabled -> car cranks doesn't start

Verified all full and partial reads - all the patches carried over, but only cranks. I'have tried cranking for an extended time as tried by scorpion, however nothing happens.

Patched full file + MS4X flasher v1.02 with checksum correction enabled -> car cranks doesn't start

MS430069 RHD EU2 full flash file with M3 Cluster, Extended DS2 patches applied starts up fine no problems - flashed normally with MS4X checksum correction enabled. Didn't need to re-sync EWS or patch UIF VIN or ISN.

Hope this helps... LC did work in this car on V56 a while ago.


RE sda2: Happy to test Alpha-n, stock apart from catless headers and exhaust. EU vehicle.

use your working version as an original file when you apply correction using ultimo. mod any v69 you want with any options then use ultimo for correction against your working file.Dont forget to disable chk correction in ms4x flasher options before flashing procedure,otherwise ultimo corrections will be overwrited. i think that latest ver of the ms4x flasher works to , i`ll double check tomorrow. One above other ,ultimo is a workaround as long as you have a working version of v69.
__________________

Last edited by scorpionreptyle; 08-17-2019 at 04:28 PM.
scorpionreptyle is offline   Reply With Quote
Old 08-17-2019, 11:21 PM   #170
Harry_de_best
Registered User
 
Join Date: Aug 2018
Location: Australia
Posts: 17
My Ride: E46 330i
Year: 2002
Model: 330i M Sport
Transmission: Manual 5spd
Just tried, ultimo corrected vs the new checksum tool resulted in the same file. Still only cranks, cranked for a while too. Don't think its the checksums, my temp needle doesn't go into the red.
Harry_de_best is offline   Reply With Quote
Old 08-19-2019, 06:06 AM   #171
scorpionreptyle
Registered User
 
Join Date: Sep 2016
Location: Bucharest
Posts: 677
My Ride: e36 330i
Year: 1997
Model: E36
Transmission: 5 spd manual
Quote:
Originally Posted by Harry_de_best View Post
Just tried, ultimo corrected vs the new checksum tool resulted in the same file. Still only cranks, cranked for a while too. Don't think its the checksums, my temp needle doesn't go into the red.

assure yourself that you have good battery amps ,it will crank but not start without proper amps. Charge battery to full before cranking again.
__________________
scorpionreptyle is offline   Reply With Quote
Old 08-19-2019, 05:09 PM   #172
sda2
Registered User
 
Join Date: Feb 2015
Location: Germany
Posts: 434
My Ride: BMW E46 330i Touring
Quote:
Originally Posted by scorpionreptyle View Post
use your working version as an original file when you apply correction using ultimo. mod any v69 you want with any options then use ultimo for correction against your working file.Dont forget to disable chk correction in ms4x flasher options before flashing procedure,otherwise ultimo corrections will be overwrited. i think that latest ver of the ms4x flasher works to , i`ll double check tomorrow. One above other ,ultimo is a workaround as long as you have a working version of v69.
MS4X flasher calculates the checksums the same way the ECUs do, it will work with every softwareversion available. There is no need to disable the correction there.
__________________
..:: Visit MS4X.net - the ultimate Siemens MS wiki ::..

Last edited by sda2; 08-20-2019 at 02:40 AM.
sda2 is offline   Reply With Quote
Old 08-20-2019, 05:42 AM   #173
Harry_de_best
Registered User
 
Join Date: Aug 2018
Location: Australia
Posts: 17
My Ride: E46 330i
Year: 2002
Model: 330i M Sport
Transmission: Manual 5spd
The car is my daily, so after the file with all the patches didn't work I simply flashed in the version with only the M3 cluster and extended DS2 logging patched. Car runs fine and start no problems, only when LC is patched does it not start.
Harry_de_best is offline   Reply With Quote
Old 08-22-2019, 08:46 AM   #174
bernardo774
Registered User
 
Join Date: Sep 2018
Location: Brazil
Posts: 45
My Ride: E46 328 B30 Swap
Year: 1999
Model: 328
Transmission: Manual
Using the MS4X with sucsess. Great Tool!

i swap MS42 to MS43.
read the ISN from MS42, wrote to 69 and do a full flash with MS4X. i keep the EWS
the first start delay 4 or 5 engines turns, and POWER!

i will try the LC and post a reply

ATENTION: aways use external power suply 20amp.
Tks for the Tean!
bernardo774 is offline   Reply With Quote
Old 08-22-2019, 08:47 AM   #175
bernardo774
Registered User
 
Join Date: Sep 2018
Location: Brazil
Posts: 45
My Ride: E46 328 B30 Swap
Year: 1999
Model: 328
Transmission: Manual
Double

Last edited by bernardo774; 08-22-2019 at 08:47 AM.
bernardo774 is offline   Reply With Quote
Old 08-22-2019, 08:54 AM   #176
cwarel
Registered User
 
Join Date: Jun 2015
Location: New York City
Posts: 852
My Ride: 330ci coupe
Quote:
Originally Posted by bernardo774 View Post
Using the MS4X with sucsess. Great Tool!

i swap MS42 to MS43.
read the ISN from MS42, wrote to 69 and do a full flash with MS4X. i keep the EWS
the first start delay 4 or 5 engines turns, and POWER!

i will try the LC and post a reply

ATENTION: aways use external power suply 20amp.
Tks for the Tean!
damn 20amp quite a lot, I use 0.5mha usb adapter form laptop does the job just fine.
cwarel is offline   Reply With Quote
Old Today, 07:29 AM   #177
Iliyasuper
Registered User
 
Join Date: May 2015
Location: Ukraine
Posts: 91
My Ride: 316 with M54b30
Some new info in wiki regarding MAF RS4
Quote:
Note: The MS4x ECUs do NOT convert the ADC return value into voltage, but keep the digital 8bit value and convert it directly into airmass.
What does it mean? Is required additional action, except of replacing maf table and patch by patch list?
ٍSo, what is required for use MAF RS4 ?
- Connect, included additional 5V wire
- Apply MAF patch with patchlist
- Replace MAF table

That is all? Correct?
Iliyasuper is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Censor is OFF



All times are GMT -5. The time now is 12:27 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
(c) 1999 - VerticalScope Inc. All rights reserved.