Rough Idle and Loud clacking noise - E46Fanatics E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 04-16-2009, 05:29 PM   #1
beemer5
Registered User
 
Join Date: Sep 2006
Location: North Wales
Posts: 10
My Ride: E46 323i SE
Rough Idle and Loud clacking noise

My E46 has just covered 222,000 miles and its been free of major issues, however today it decides to misfire which clears itself and then returns, so I get the scanner on it and there are no faults coming up, whilst checking it there is a loud clacking noise which is similar to a bolt flying around the flywheel housing [ just a single clack every so often], our thoughts are pointing towards the ccv under the manifold as there is a fairly loud suction noise, which disappears if you pull out the oil dipstick a couple of inches. The vacuum at the oil filler cap is mild which I think is correct. Any ideas folks?


Sean
__________________
beemer5 is offline   Reply With Quote
Old 04-16-2009, 05:34 PM   #2
Solidjake
Shifting
 
Solidjake's Avatar
 
Join Date: May 2008
Location: NYC/Philly
Posts: 31,786
My Ride: 2013 328i 6MT
Do you think maybe the cracking sound is the DISA? Check my vid on how to disconnect the DISA valve

Solidjake is offline   Reply With Quote
Old 04-16-2009, 06:02 PM   #3
beemer5
Registered User
 
Join Date: Sep 2006
Location: North Wales
Posts: 10
My Ride: E46 323i SE
I disconnected the DISA whilst running and it did not appear to make any difference. The clacking noise which incidentaly dissapeared [I think] as on my journey home this evening from the office, some 22 miles I cannot recall hearing anything!.
It seems to come from somewhere below the inlet manifold which suggests to me possibly the ccv. There is definitely a suction noise from the same arae but as yet I have not been able to pinpoint it.

Update; Well on Saturday morning I purchased a new ccv and various hoses, I set about replacing the valve assembly by removing the inlet manifold, completed the job late afternoon, car started immediately but feels down on power a little, also with ignition on you can hear the idle control valve buzzing, so I removed to see what could be wrong, the rotatinf flap is open and there is around a 1.5mm gap. Put it back and it still buzzes, also it seems down on power/acceleration and also stalls when coming to stop at junctions etc. Does it need a new idle control valve?
__________________

Last edited by beemer5; 04-19-2009 at 10:30 AM.
beemer5 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON



All times are GMT -5. The time now is 02:29 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
(c) 1999 - VerticalScope Inc. All rights reserved.