Turn off CD Changer/ Bluetooth device on Ignition off - E46Fanatics E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Go Back   E46Fanatics > Tuning & Tech > Mobile Electronics Forum

Mobile Electronics Forum
Have all your A/V and electronics questions answered here. Ipods, A/V, Radar Detectors Oh My!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 02-26-2020, 02:12 AM   #1
NewDadOldCar
Registered User
 
Join Date: Jun 2019
Location: Germany
Posts: 88
My Ride: 330Ci
Year: 2000
Model: E46 pre face Lift
Transmission: 5 spd Manual
Turn off CD Changer/ Bluetooth device on Ignition off

Hello Everyone,

I have a 330ci cabrio pre facelift with a H&K system with the small nav screen and CD changer in the trunk.

I lately installed a Bluetooth device for streaming audio and calls from a brand called yatour ( might be no one is heard of it). I use the CD changer connectors to connect. It had no extra wires for the ACC switched power.

Lately i have noticed that the Bluetooth device stays on even after shutting down the car hours ago. so i thought it might be the device and unplugged it and plugged the CD changer back in, the CD changer never goes to sleep.

I have to pull out fuse 7 and 41 if i have to leave the car for more than 2 days. its slowly annoying me.

Any one have some good ideas to fix this?
May be make the fuse 7 or 41 as switched power
or make a switched power just for the CD changer ?

Thanks guys, you have been very helpful in the past, hopefully i can contribute one day or the other with more content of my own.

Cheers
Attached Thumbnails
Click image for larger version

Name:	s-l1600.jpg
Views:	20
Size:	90.1 KB
ID:	794279   Click image for larger version

Name:	s-l1601.jpg
Views:	20
Size:	47.0 KB
ID:	794281   Click image for larger version

Name:	s-l1602.jpg
Views:	20
Size:	65.4 KB
ID:	794283   Click image for larger version

Name:	s-l1603.jpg
Views:	24
Size:	46.1 KB
ID:	794285  

NewDadOldCar is offline   Reply With Quote
Old 02-26-2020, 03:07 PM   #2
NewDadOldCar
Registered User
 
Join Date: Jun 2019
Location: Germany
Posts: 88
My Ride: 330Ci
Year: 2000
Model: E46 pre face Lift
Transmission: 5 spd Manual
come on guys! atleast point me in the right direction.

Everything i read was either a dead end or didnot solve my problem-
NewDadOldCar is offline   Reply With Quote
Old 02-27-2020, 06:55 AM   #3
markusmarkus
Registered User
 
Join Date: Jul 2008
Location: USA
Posts: 9,929
My Ride: 2018 M240i
Ok. The lower amp fuse (5 amps) is always present. Itís used by the head unit to retain radio presets. The other fuse is switched power. That is, power is supplied via the fuse only when the ignition switch is not in the off position. If you look at the fuse layout card the upper left row of fuses have power at all times as this is where fuse 7 is located. Fuse 41 is located in the bottom right row. This section gets switched power. Your problem means that this lower right section is getting power even with the key out OR the head unit is drawing too much power via fuse 7. Iím betting the problem is the later circumstance. Try pulling just fuse 7 and see what happens.
markusmarkus is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-27-2020, 07:36 AM   #4
NewDadOldCar
Registered User
 
Join Date: Jun 2019
Location: Germany
Posts: 88
My Ride: 330Ci
Year: 2000
Model: E46 pre face Lift
Transmission: 5 spd Manual
Quote:
Originally Posted by markusmarkus View Post
Ok. The lower amp fuse (5 amps) is always present. It's used by the head unit to retain radio presets. The other fuse is switched power. That is, power is supplied via the fuse only when the ignition switch is not in the off position. If you look at the fuse layout card the upper left row of fuses have power at all times as this is where fuse 7 is located. Fuse 41 is located in the bottom right row. This section gets switched power. Your problem means that this lower right section is getting power even with the key out OR the head unit is drawing too much power via fuse 7. I'm betting the problem is the later circumstance. Try pulling just fuse 7 and see what happens.
thanks for the reply

OK.. I'll pull fuse 7 tonight and see what happens.
BTW since i got the car last summer, my passenger side doors don't unlock using the key fob nor using the central button in the car. But it locks using the key fob, do you think it might be related?

Last edited by NewDadOldCar; 03-03-2020 at 10:14 AM.
NewDadOldCar is offline   Reply With Quote
Old 02-28-2020, 06:15 AM   #5
markusmarkus
Registered User
 
Join Date: Jul 2008
Location: USA
Posts: 9,929
My Ride: 2018 M240i
Not related. It sounds like the general module (GM5) is the culprit. Go to www.bmwgm5.com to learn more.
markusmarkus is offline   Reply With Quote
Old 03-03-2020, 10:14 AM   #6
NewDadOldCar
Registered User
 
Join Date: Jun 2019
Location: Germany
Posts: 88
My Ride: 330Ci
Year: 2000
Model: E46 pre face Lift
Transmission: 5 spd Manual
Quote:
Originally Posted by NewDadOldCar View Post
thanks for the reply

OK.. I'll pull fuse 7 tonight and see what happens.
BTW since i got the car last summer, my passenger side doors don't unlock using the key fob nor using the central button in the car. But it locks using the key fob, do you think it might be related?
Haven't done it yet. But some one told me that before i turn the car off, if i change the mode to FM, and then turn off the car, the CD changer switches off after 15 minutes. Will give that a try tonight!

Last edited by NewDadOldCar; 03-09-2020 at 05:46 AM.
NewDadOldCar is offline   Reply With Quote
Old 03-30-2020, 05:20 AM   #7
NewDadOldCar
Registered User
 
Join Date: Jun 2019
Location: Germany
Posts: 88
My Ride: 330Ci
Year: 2000
Model: E46 pre face Lift
Transmission: 5 spd Manual
Social Distancing killed my Battery

So a small Update,

Left my car in FM mode and stayed unused because of work from Home, and yesterday the car did not start. INPA says 9,37V battery.

So leaving it on radio doesn't help..

May be during Easter i have to do the battery drain Test.

I'll keep it posted. Any more suggestions, tips and trick welcome.

Cheers guys
Stay safe
NewDadOldCar is offline   Reply With Quote
Old 04-09-2020, 09:19 AM   #8
NewDadOldCar
Registered User
 
Join Date: Jun 2019
Location: Germany
Posts: 88
My Ride: 330Ci
Year: 2000
Model: E46 pre face Lift
Transmission: 5 spd Manual
So I left the Fuse #7 removed for almost 10 days and started the car today. No battery drain!
The Nav screen turned on when i started the car, but the controls didn't work, and no radio.

What all does Fuse #7 control.. How can i fix this?

Any clues?
NewDadOldCar is offline   Reply With Quote
Old 04-12-2020, 08:20 AM   #9
NewDadOldCar
Registered User
 
Join Date: Jun 2019
Location: Germany
Posts: 88
My Ride: 330Ci
Year: 2000
Model: E46 pre face Lift
Transmission: 5 spd Manual
Anyone?
Is it the radio or the nav or the amp??

Sent from my SM-G970F using Tapatalk
NewDadOldCar is offline   Reply With Quote
Old 04-24-2020, 12:26 AM   #10
NewDadOldCar
Registered User
 
Join Date: Jun 2019
Location: Germany
Posts: 88
My Ride: 330Ci
Year: 2000
Model: E46 pre face Lift
Transmission: 5 spd Manual
So i read and read, looks like fuse 41 does the same thing.

I pluggesd everything back in left the door and trunk open tricking the car to go to sleep.
The blower goes off, the navigation and the display upfront goes off. But I still have connection to the bluetooth device which connects to the CD Changers pins. Which points in the direction that radio is keeping it alive.

I unplugged fuse 41 and after half hour it sparks when I try to plug it in.

A used radio here in Europe is over 80Ä. So before I buy one I need some suggestions from you guys.

Anyone??
Cherrs

Sent from my SM-G970F using Tapatalk
NewDadOldCar is offline   Reply With Quote
Old 04-24-2020, 02:06 AM   #11
bmwdud121
Registered User
 
Join Date: Nov 2015
Location: Melbourne
Posts: 142
My Ride: 2002 330i
How handy are you with electronics? You could remove the power wire from the cd changer plug and use an ACC wire to power your device instead. Not too tricky, and you can just splice off an ACC wire in the trunk.
bmwdud121 is offline   Reply With Quote
Old 04-24-2020, 02:23 AM   #12
NewDadOldCar
Registered User
 
Join Date: Jun 2019
Location: Germany
Posts: 88
My Ride: 330Ci
Year: 2000
Model: E46 pre face Lift
Transmission: 5 spd Manual
Thanks for the reply..

I'm pretty handy with stuff.. but what if the CD changer is just awake because the radio is awake??

So I cut and splice but then if the radio is awake the whole time then it was all for nothing..

I am going to remove the bluetooth adapter ( BTA) during the next week and see if it will still kill the battery .. if it doesn't then I'll try your tip.

Cheers..

P.s. when I bought the car the radio was not working and it didn't have the BTA , just the CD changer. After hours of reading and removing fuses I found that the fuse on the BM24/54 was blown.. so may be the radio was the culprit from the start..

Sent from my SM-G970F using Tapatalk
NewDadOldCar is offline   Reply With Quote
Old 04-24-2020, 03:50 AM   #13
bmwdud121
Registered User
 
Join Date: Nov 2015
Location: Melbourne
Posts: 142
My Ride: 2002 330i
Hmm. checked this one? https://www.newtis.info/tisv2/a/en/e.../radio/n1pGqsD
Fuse #7 should control the radio, AM/FM antenna, nav screen, and amp. I would leave the #7 fuse in, and start by disconnecting everything on #7 (unplug the amp, radio etc.), confirming that there's no draw with everything out, then plug back in one by one and see what happens.
bmwdud121 is offline   Reply With Quote
Old 04-24-2020, 05:21 AM   #14
NewDadOldCar
Registered User
 
Join Date: Jun 2019
Location: Germany
Posts: 88
My Ride: 330Ci
Year: 2000
Model: E46 pre face Lift
Transmission: 5 spd Manual
Thanks, this is the Plan this Weekend..

Sent from my SM-G970F using Tapatalk
NewDadOldCar is offline   Reply With Quote
Old 04-25-2020, 09:19 AM   #15
NewDadOldCar
Registered User
 
Join Date: Jun 2019
Location: Germany
Posts: 88
My Ride: 330Ci
Year: 2000
Model: E46 pre face Lift
Transmission: 5 spd Manual
So radio out, now wait 15 Minutes ..
Looks rusted at the two connectors

Sent from my SM-G970F using Tapatalk
NewDadOldCar is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON



All times are GMT -5. The time now is 03:19 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
(c) 1999 - VerticalScope Inc. All rights reserved.