What's the general consensus on Eonon radio units? - Page 3 - E46Fanatics E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Go Back   E46Fanatics > Tuning & Tech > Mobile Electronics Forum

Mobile Electronics Forum
Have all your A/V and electronics questions answered here. Ipods, A/V, Radar Detectors Oh My!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 06-27-2019, 04:55 PM   #41
EugeneF
Registered User
 
Join Date: May 2019
Location: Brooklyn, NY
Posts: 48
My Ride: 2005 ZHP Sedan
Quote:
Originally Posted by FWSIV View Post
Thinking about getting the GA9350 for my son's car. Some questions I have about the unit-
For apple car play- do you need a dongle to make this work? Or will it work with BT?
Where is everyone running the USB wires off the back of the unit?
Does anyone use that USB port on the front of the unit?

TIA
My ga9150kw has 2 usb's Coming out the back. So I plugged the adapter into one of the cables and then plugged the other end behind the bracket (I ordered the bracket with 2 USB ports made by dynavin), so that way it's not hanging on the interior of the car (hope that made sense)

Last edited by EugeneF; 06-27-2019 at 06:49 PM.
EugeneF is offline   Reply With Quote
Old 06-27-2019, 05:10 PM   #42
oregonbmw
Registered User
 
Join Date: Jun 2017
Location: Portland, Oregon
Posts: 37
My Ride: 2004 330cic
Year: 2004
Model: 330 cic
Transmission: 6 speed manual
Do you have a link to this bracket ?
__________________
2004 330cic 6 speed, grey-green, blue top, natural brown interior









To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

oregonbmw is offline   Reply With Quote
Old 06-27-2019, 06:49 PM   #43
EugeneF
Registered User
 
Join Date: May 2019
Location: Brooklyn, NY
Posts: 48
My Ride: 2005 ZHP Sedan
Quote:
Originally Posted by oregonbmw View Post
Do you have a link to this bracket ?
https://www.jandtdistributing.com/pr...19278196572217
EugeneF is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-01-2019, 01:08 PM   #44
FWSIV
Registered User
 
Join Date: Mar 2007
Location: Chapel Hill, NC
Posts: 28
My Ride: 1992 535, 1987 325iS
Quote:
Originally Posted by EugeneF View Post
My ga9150kw has 2 usb's Coming out the back. So I plugged the adapter into one of the cables and then plugged the other end behind the bracket (I ordered the bracket with 2 USB ports made by dynavin), so that way it's not hanging on the interior of the car (hope that made sense)
That's my fall back plan is to get one of these brackets that has the USB ports.

Another question I have, that I can't find an answer too, is- Do Eonon's support satellite radio?
__________________
Chip
1989 325i race car
2001 330i (son's car)
1987 325iS
2010 328i- 6sp (wife's car)
FWSIV is offline   Reply With Quote
Old 07-05-2019, 05:16 AM   #45
Millatime
Registered User
 
Join Date: Jul 2019
Posts: 19
I'm looking to buy one of the Android units, either Xtrons or similar. I have the DSP Harmon Kardon system in my 04 330ci and have read conflicting info on whether or not I need the extension harness that runs to the trunk. What is the actual truth on this?
Millatime is offline   Reply With Quote
Old 07-05-2019, 05:38 AM   #46
stück/piece
Registered User
 
Join Date: Mar 2017
Location: London
Posts: 120
My Ride: 325 Convertible
Transmission: Manual
If you have the factory navigation unit, you need the extention harness as the amplifier (BM54) is in the boot/trunk.
If you have a business cd head unit you don't need it.
stück/piece is offline   Reply With Quote
Old 07-05-2019, 05:43 AM   #47
Millatime
Registered User
 
Join Date: Jul 2019
Posts: 19
Quote:
Originally Posted by stück/piece View Post
If you have the factory navigation unit, you need the extention harness as the amplifier (BM54) is in the boot/trunk.
If you have a business cd head unit you don't need it.
Thank you for the quick reply. Alright, I'll get the head unit ordered now. I have been apprehensive because I wasn't sure if I needed the $70 harness. I have seen the harness the plugs into the back as I have already bought and installed the aux cord input into the rear port and saw the connections were the same as someone else that posted their Android unit came with a different plug. That confused the hell outta me. Ok, cool, one more thing I'll be installing this long holiday weekend!
Millatime is offline   Reply With Quote
Old 07-05-2019, 01:07 PM   #48
oregonbmw
Registered User
 
Join Date: Jun 2017
Location: Portland, Oregon
Posts: 37
My Ride: 2004 330cic
Year: 2004
Model: 330 cic
Transmission: 6 speed manual
My 2004 330cic did come with the navigation system, so it would need the additional $70 harness.
However, my car already had a Dynavin head unit from 2011/12 installed in it and it looks like a harness was already installed when it was installed. Unfortunately, it also looks like while the signals are all there from the Dynavin setup, they are mapped to the plug differently from the way the Eonon is mapped, even though the actual plug that goes into both head units is the same.

I am now faced with a couple choices, either get the Eonon harness and run that through car or cut the wires at the existing wire harness plug end and rewire them to match the Eonon wiring. I am first going to try the later this weekend, hopefully that will work out (I don't know why it wouldn't, but then again I had fantasies about just being able to unplug the old unit and plugin the new unit, which were dashed by the wiring diff).

So what this may mean for others doing installs is that if you buy a particular brand of radio, you will likely need to buy their wiring harness and not somebody else's to ensure the wiring matches at the connector.
__________________
2004 330cic 6 speed, grey-green, blue top, natural brown interior









To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

oregonbmw is offline   Reply With Quote
Old 07-06-2019, 03:11 AM   #49
GuyG
Registered User
 
Join Date: Jan 2013
Location: London UK
Posts: 173
My Ride: Topaz Touring
Year: 5/02
Model: 330i M Sport Touring
Transmission: Automatic
Quote:
Originally Posted by oregonbmw View Post
However, my car already had a Dynavin head unit from 2011/12 installed in it and it looks like a harness was already installed when it was installed. Unfortunately, it also looks like while the signals are all there from the Dynavin setup, they are mapped to the plug differently from the way the Eonon is mapped, even though the actual plug that goes into both head units is the same.
Can you not just re-pin that plug?

Sent from my HTC U11 using E46Fanatics mobile app
GuyG is offline   Reply With Quote
Old 07-06-2019, 06:19 AM   #50
GuyG
Registered User
 
Join Date: Jan 2013
Location: London UK
Posts: 173
My Ride: Topaz Touring
Year: 5/02
Model: 330i M Sport Touring
Transmission: Automatic
Quote:
Originally Posted by GuyG View Post
One issue I am having is the DAB radio app will not play sound. It has perfect signal and I can see all the radio stations but no sound. I am wondering if the Eonon V0054 DAB+ unit I have connected is not compatible with android 9.0 ??? I have sent Eonon an email today for help.

Three days in.........will try and remember to post again after more time testing.
So after daily emails with Eonon customer service trying to resolve the DAB+ sound problem we have tried:-
1) deleting the new version of the DAB+ app and running the old version. This resulted in having sound but broken sound coming in and out every 1/2 second or so.
2) upgrading the software to the GA9350 - no improvement with either app.

My suspicion is that Eonon have not created software/app for the V0054 to work with android 9.0 even though they advertise the GA9350 on their website to run the V0054 for DAB+ radio! As of Monday 1st July I have been asked by Eonon to give them some time to resolve the issue (that should never have existed before putting the GA9350 to market!). Perhaps they are now creating an app that will work??
I will give them until some time next week to provide a solution before requesting a full refund if they cannot, and will go back to using my trusty GA8150a.
GuyG is offline   Reply With Quote
Old 07-06-2019, 10:25 AM   #51
oregonbmw
Registered User
 
Join Date: Jun 2017
Location: Portland, Oregon
Posts: 37
My Ride: 2004 330cic
Year: 2004
Model: 330 cic
Transmission: 6 speed manual
Quote:
Originally Posted by GuyG View Post
Can you not just re-pin that plug?
That is effectively what I am trying.
Unfortunately I can't find a way to non destructively remove the pins from the connector. I was hoping to find a a male and female connector locally, I haven't been able to find the female and the male connectors take a week or more to get.
So I am going to cut the wires, put bullet connectors on them, and then plug them together the way they need to be to match the Eonon head unit. Hopefully then everything will be compatible and it will work. By using bullet connectors instead of butt connectors, I can always go back to the Dynavin head unit if need be.
__________________
2004 330cic 6 speed, grey-green, blue top, natural brown interior









To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

oregonbmw is offline   Reply With Quote
Old 07-07-2019, 10:16 PM   #52
oregonbmw
Registered User
 
Join Date: Jun 2017
Location: Portland, Oregon
Posts: 37
My Ride: 2004 330cic
Year: 2004
Model: 330 cic
Transmission: 6 speed manual
I re-pinned/swizzled the pins to the connector that goes from the old dynavin harness to the Eonon connector. The radio works and sounds good.

But the steering wheel controls don't seem to work. On the Dynavin connector there were both Can Bus TX and RX pin connections. But on the Eonon plug, there is no connection for the CanBus RX, it just has the TX. Assuming if the steering controls come through the CanBus signals, it could be that the canbus decoder that (I assume) the Dynavin harness has is some how not compatible?

The other difficulty I have had is the antenna conection. The harness in the car that the Dynavin was connected with uses a straight motorola connector that plugged into a corded and flat to the back connection to the old unit. Directly plugging the straight motorola into the Eonon doesn't allow for clearance to put the radio in. You would think that finding a 90 degree motorola connector to female connector would be easy and trivial, but not so. The Eonon came with a 90 degree motorola to what I think is a EU-10 or EU-20 connector. So I have ordered this https://smile.amazon.com/gp/product/B000329HF4 in hopes that it will allow me to connect the two ends together.
__________________
2004 330cic 6 speed, grey-green, blue top, natural brown interior









To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

oregonbmw is offline   Reply With Quote
Old 07-08-2019, 01:45 PM   #53
Stuttgart330
Registered User
 
Join Date: Dec 2007
Location: The Desert
Posts: 528
My Ride: 05 330CIC ZHP
Quote:
Originally Posted by 205_zhp View Post
I like mine a lot but it’s taken some tweaking to get it how I like it. I still have problems with people being able to hear me on Bluetooth phone calls though. The CarPlay adapter works perfectly (minus problems with people hearing me on calls)Trying to figure that out

I have this exact unit - just installed 3 days ago - having issues with radio reception - sometimes works great, othertimes I can't pick up anything. Plus, I cannot modify the main screen like you show - how did you move the icons around?
Other than the radio issue, I'm really pleased with the unit..
__________________

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

2005 330CiC ZHP Hellrot - (mine)
2006 F350 Diesel CC - (Toy Hauler)
2009 528i Spacegrau Metallic - (wifes)
Stuttgart330 is offline   Reply With Quote
Old 07-08-2019, 02:10 PM   #54
Silverdogz
Registered User
 
Join Date: Jul 2015
Location: Spokane, WA
Posts: 1,155
My Ride: '02 330Ci, '04 330i
Year: 2004
Model: BMW 330i ZHP
Transmission: Manual 6spd
Quote:
Originally Posted by Stuttgart330 View Post
I have this exact unit - just installed 3 days ago - having issues with radio reception - sometimes works great, othertimes I can't pick up anything. Plus, I cannot modify the main screen like you show - how did you move the icons around?
Other than the radio issue, I'm really pleased with the unit..
It's not so hard, you need to get into the main settings and change the location. That cleared up alot of issue for me. XDADevelopers android HU forum is really helpful about this stuff.
__________________
DSC MK60 Replacement and INPA Install:
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
Silverdogz is offline   Reply With Quote
Old 07-08-2019, 02:41 PM   #55
205_zhp
Registered User
 
Join Date: Feb 2012
Location: Huntsville, AL
Posts: 191
My Ride: 2005 BMW 330i ZHP
Year: 2005
Model: 330i ZHP
Transmission: 6MT
Quote:
Originally Posted by Stuttgart330 View Post
I have this exact unit - just installed 3 days ago - having issues with radio reception - sometimes works great, othertimes I can't pick up anything. Plus, I cannot modify the main screen like you show - how did you move the icons around?
Other than the radio issue, I'm really pleased with the unit..


Moving the apps around can be a little finicky. You just have to select and hold it with your finger and you should be able to drag it around. You can go into settings (password is 8888 I believe) and make some adjustments to the settings to get your location right.
__________________

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

05 BMW • 330i • ZHP • DINAN3

Instagram @205_zhp
205_zhp is online now   Reply With Quote
Old 07-08-2019, 03:53 PM   #56
Stuttgart330
Registered User
 
Join Date: Dec 2007
Location: The Desert
Posts: 528
My Ride: 05 330CIC ZHP
Figured it out - in factory settings. Hopefully that helps, it was set to Europe. On another note - the steering wheel app doesn't seem to work - I assume others have same issue?
__________________

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

2005 330CiC ZHP Hellrot - (mine)
2006 F350 Diesel CC - (Toy Hauler)
2009 528i Spacegrau Metallic - (wifes)
Stuttgart330 is offline   Reply With Quote
Old 07-08-2019, 03:54 PM   #57
Stuttgart330
Registered User
 
Join Date: Dec 2007
Location: The Desert
Posts: 528
My Ride: 05 330CIC ZHP
One thing I do wish you could do is a split screen - with this huge 9" screen, it just makes sense...
__________________

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

2005 330CiC ZHP Hellrot - (mine)
2006 F350 Diesel CC - (Toy Hauler)
2009 528i Spacegrau Metallic - (wifes)
Stuttgart330 is offline   Reply With Quote
Old 07-08-2019, 03:57 PM   #58
205_zhp
Registered User
 
Join Date: Feb 2012
Location: Huntsville, AL
Posts: 191
My Ride: 2005 BMW 330i ZHP
Year: 2005
Model: 330i ZHP
Transmission: 6MT
Quote:
Originally Posted by Stuttgart330 View Post
One thing I do wish you could do is a split screen - with this huge 9" screen, it just makes sense...


You should be able to
__________________

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

05 BMW • 330i • ZHP • DINAN3

Instagram @205_zhp
205_zhp is online now   Reply With Quote
Old 07-08-2019, 04:17 PM   #59
Stuttgart330
Registered User
 
Join Date: Dec 2007
Location: The Desert
Posts: 528
My Ride: 05 330CIC ZHP
Quote:
Originally Posted by 205_zhp View Post
You should be able to

Well I haven't figured it out yet... and still for some reason I can only move the small app icons on my main screen - cannot move those larger widgets at all..odd..
__________________

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

2005 330CiC ZHP Hellrot - (mine)
2006 F350 Diesel CC - (Toy Hauler)
2009 528i Spacegrau Metallic - (wifes)
Stuttgart330 is offline   Reply With Quote
Old 07-10-2019, 04:40 PM   #60
wadd3456
Registered User
 
Join Date: Sep 2005
Location: VT
Posts: 80
My Ride: Nothing
Sorry to piggy back on your post, but it seemed relevant. Ive got a 2001 m3 the business tape player with cd changer in the trunk. I ordered the GA9350B recently. Its on backorder for another week or so.

Eonon is unable to tell me if the unit is compatible with my car. They want me to rip the radio out just to see if it complies with this https://www.eonon.com/UserFiles/imag...9350b/note.png

Id like to avoid ripping the dash apart twice, if possible. Can anyone tell me if my M works with the Eonon?
Attached Thumbnails
Click image for larger version

Name:	301D5A44-A508-4F85-8242-FDE6D69E1BB6_1562794748439.jpeg
Views:	55
Size:	475.8 KB
ID:	779267  

Last edited by wadd3456; 07-10-2019 at 04:42 PM.
wadd3456 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON



All times are GMT -5. The time now is 10:48 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
(c) 1999 - VerticalScope Inc. All rights reserved.