ZF5hp Swap - Warnings and Codes - E46Fanatics E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Go Back   E46Fanatics > Tuning & Tech > Driveline, Engine & DME Tuning

Driveline, Engine & DME Tuning
Talk about driveline improvements, NA tuning and DME tuning your E46 BMW here. This includes diffs, intakes, exhausts, chips, software and OBD tuning.

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 06-03-2019, 02:43 PM   #1
roshman5000
Registered User
 
Join Date: Jul 2017
Location: Texas
Posts: 31
My Ride: BMW
Year: 2003
Model: 325i Sedan
Transmission: Steptronic Automatic
ZF5hp Swap - Warnings and Codes

2003 325i US Sedan - Prod date 10/02

Results - After swapping 199k mile unit for a 50K mile unit.

Ran great for 2 days and started the limping thing.
Returned to my local shop, install mechanic in LockHart.
I cleared the codes and drove the car back home.
Babied the car. Next day the car ran fine.

I had to leave for a trip and left the car at the airport for 6 days.

Returned from trip. Ran fine for a minute. Here comes a cog wheel after stopping for a Gatorade. Shut the car on a off a few times, rolled thru gears while sitting. Limped home. Noticed the shifts are now lunging hard.

I read about issue with battery could cause issue if low V.
Installed a new one anyway.

Car is now an on and off limp Cog wheel / selector issue.
Even notice I'm in S when I'm really in P.
Here's my current codes with SES and Cog light next to dash gear display...

084 - 54 FET2 Control Unit fault, internal 5
114 - 72 Steptronic Switch
060 3C P0705 Trasmission switch
083 53 FET1, Control unit fault, internal 4

Wants and Needs
An idea what this will run me in labor to resolve? Can we acess these issue without dropping the xmish?
What parts do we need to address..i.e. transmission harness, internal or external modules?

I got these codes from Terry Sayther son this AM, here in ATX, but his transmission guy is away for vacation for upto 2 weeks.

Vendor says they will cover parts only.
Depending on the time of day....
What sucks is, the car either runs great 80-100 mph when on the toll road without the COG Wheel of Limp
...or like a bucking bronco at 30-40 mph going thru the gears when the cog appears.

I do see ABS wheel-speed sensor codes, but can't compute they are relevant.
No faults for DME, EWS, SZM
Worse case scenario, I'll make a fancy looking outdoor BBQ pit out of this ride.


Last edited by roshman5000; 06-03-2019 at 03:51 PM. Reason: add
roshman5000 is offline   Reply With Quote
Old 06-03-2019, 11:51 PM   #2
armenh7
Registered User
 
Join Date: Dec 2016
Location: California
Posts: 8,344
My Ride: 2002 325i
Ask in the general forum for more exposure
__________________
armenh7 is offline   Reply With Quote
Old 06-04-2019, 04:31 AM   #3
roshman5000
Registered User
 
Join Date: Jul 2017
Location: Texas
Posts: 31
My Ride: BMW
Year: 2003
Model: 325i Sedan
Transmission: Steptronic Automatic
Reposted and edited to correct forum.
"Thanks", said the noob.

Last edited by roshman5000; 06-04-2019 at 05:12 AM. Reason: add
roshman5000 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Censor is OFF



All times are GMT -5. The time now is 11:16 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
(c) 1999 - VerticalScope Inc. All rights reserved.