Finally a sillieidiot progress thread… - Page 11 - E46Fanatics E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Go Back   E46Fanatics > E46 BMW > The Showroom

The Showroom
This is the place to show off your BMW to other members of the community. Post pictures and videos of your car and the modifications you have done to it. If you need a picture of something on a coupe, sedan, convertible or touring you will probably find it here!

Reply
 
Thread Tools Search this Thread Rating: Thread Rating: 12 votes, 5.00 average. Display Modes
Old 02-19-2018, 06:30 PM   #201
Brian N
Registered User
 
Join Date: Oct 2004
Location: The OC
Posts: 10,436
My Ride: 2001 330i Jet Black
Who is this Brian you speak of and why did he find you this shell?

Also please don't bump the thread. LOL
__________________

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
Brian N is offline   Reply With Quote
Old 02-19-2018, 06:37 PM   #202
sillieidiot
Registered User
 
Join Date: Sep 2004
Location: the OC
Posts: 32,585
My Ride: '06 AW 330ci
Send a message via AIM to sillieidiot
Quote:
Originally Posted by Brian N View Post
Who is this Brian you speak of and why did he find you this shell?

Also please don't bump the thread. LOL
LOL too late. I bumped it literally seconds after I posted
__________________
I like to reply to threads with 0 posts




Have a lighting problem? Read this first:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
sillieidiot is offline   Reply With Quote
Old 02-20-2018, 01:58 PM   #203
tuscan1205
Registered User
 
Join Date: Mar 2008
Location: SV, Arizona
Posts: 1,252
My Ride: e46 325CI, w212 E550
Awesome! I still have my oem m3 fenders sitting in a box in my garage. I'm glad you're sticking with the mtech 2. I should've went that way the first time around. Recently I had an oem m3 muffler welded into place and ditched the straight pipes. I couldn't be more happy with how quiet it is now. The straight pipes were terrible under highway conditions.

Please keep us posted a year from now when the work is complete lol.
__________________



To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


'02 e46 325CI & '12 w212 E550


Last edited by tuscan1205; 02-20-2018 at 08:06 PM.
tuscan1205 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-20-2018, 02:56 PM   #204
sillieidiot
Registered User
 
Join Date: Sep 2004
Location: the OC
Posts: 32,585
My Ride: '06 AW 330ci
Send a message via AIM to sillieidiot
Quote:
Originally Posted by tuscan1205 View Post
Awesome! I still have my oem m3 fenders sitting in a box in my garage. I'm glad your sticking with the mtech 2. I should've went that way the first time around. Recently I had an oem m3 muffler welded into place and ditched the straight pipes. I couldn't be more happy with how quite it is now. The straight pipes were terrible under highway conditions.

Please keep us posted a year from now when the work is complete lol.
Yeah I'm still figuring out the exhaust. I know I want to go quad because after these fenders it'll look wider and the tips on just one side will look too small. But I don't know what I'm going to do. Currently I'm debating between grabbing an M3 muffler of some kind and cutting out the spare tire area for it, then route the exhaust out. Or just run pipes from my existing setup.

lol, yeah I'll try to drop by between projects to post any updates.
__________________
I like to reply to threads with 0 posts




Have a lighting problem? Read this first:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
sillieidiot is offline   Reply With Quote
Old 02-23-2018, 03:30 PM   #205
sillieidiot
Registered User
 
Join Date: Sep 2004
Location: the OC
Posts: 32,585
My Ride: '06 AW 330ci
Send a message via AIM to sillieidiot
Hit this like a month ago. Finally got the car up to check. Looks nasty Now I know I gotta replace that brace when the car comes back.





Dropped off the car yesterday as well

__________________
I like to reply to threads with 0 posts




Have a lighting problem? Read this first:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
sillieidiot is offline   Reply With Quote
Old 02-24-2018, 06:43 AM   #206
Eurobahn BMW
Eurobahn BMW
 
Join Date: Dec 2006
Location: Greensboro, NC
Posts: 4,894
My Ride: BMW
Tastefully done very nice!
Eurobahn BMW is offline   Reply With Quote
Old 02-24-2018, 06:45 AM   #207
Eurobahn BMW
Eurobahn BMW
 
Join Date: Dec 2006
Location: Greensboro, NC
Posts: 4,894
My Ride: BMW
tastefully done very nice!
Eurobahn BMW is offline   Reply With Quote
Old 03-04-2018, 08:04 AM   #208
sillieidiot
Registered User
 
Join Date: Sep 2004
Location: the OC
Posts: 32,585
My Ride: '06 AW 330ci
Send a message via AIM to sillieidiot
Quote:
Originally Posted by Eurobahn BMW View Post
Tastefully done very nice!
__________________
I like to reply to threads with 0 posts




Have a lighting problem? Read this first:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
sillieidiot is offline   Reply With Quote
Old 03-04-2018, 05:11 PM   #209
BLAMM0
Registered User
 
Join Date: Nov 2014
Location: Lithuania
Posts: 31
My Ride: 325i, Audi Coupe
Great looking car Can you please tell me how you fastened the scrape plates? Thanks.
BLAMM0 is offline   Reply With Quote
Old 03-04-2018, 08:52 PM   #210
YoitsTmac
Registered User
 
Join Date: Apr 2015
Location: SoCal
Posts: 2,558
My Ride: 01 330Ci "Mia"
I like this car. I just finished reading cover to cover. I'm feeling many emotions, mainly jealousy...I want the bumpers and the roof. I LOVE the fender job done with the front - incredible. Phenomenal job, looks fantastic. Love it
__________________
|
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
|


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

BMWCCA GGC: 530872
YoitsTmac is offline   Reply With Quote
Old 03-06-2018, 07:37 AM   #211
sillieidiot
Registered User
 
Join Date: Sep 2004
Location: the OC
Posts: 32,585
My Ride: '06 AW 330ci
Send a message via AIM to sillieidiot
Quote:
Originally Posted by BLAMM0 View Post
Great looking car Can you please tell me how you fastened the scrape plates? Thanks.
I just used double sided tape so that it's strong enough to stay on while driving and stuff, but weak enough so that it lets go instead of destroying my bumper. Although it doesn't do anything if something hits the actual bumper first lol

Quote:
Originally Posted by YoitsTmac View Post
I like this car. I just finished reading cover to cover. I'm feeling many emotions, mainly jealousy...I want the bumpers and the roof. I LOVE the fender job done with the front - incredible. Phenomenal job, looks fantastic. Love it
Much thanks My bumpers are just mt2 though except for the mold on the front.
sillieidiot is offline   Reply With Quote
Old 09-15-2018, 05:22 PM   #212
sillieidiot
Registered User
 
Join Date: Sep 2004
Location: the OC
Posts: 32,585
My Ride: '06 AW 330ci
Send a message via AIM to sillieidiot
Ok so I got my car back. Sadly, it's not done I had an issue with the CF trunk that I bought from Streamline. Fitment was not as described and going back and forth with the seller for months so that delayed the process Since I needed to keep test fitting/take pictures of the trunk on the car and stuff. And I could only do this every 2-3 weeks because I'm out of state when I work. Trunk issue still not resolved, so I'll be keeping my current trunk for the mean time.

Anyways, I had to take it back because I needed to smog the car. I have been away for work since I dropped off the car so I haven't had time. So I had Wayne put on my trunk, didn't matter about fitment, I just needed it to be fit to drive. Got the car back like 8/14. Then I left for work, then right after went to Vietnam to take care of something.

Came back 8/28.

Got the car smogged. So I figured since I have the car back, I'm going to take care of a few things that I have been meaning to do before I give it back to the shop.

9/3 (Labor Day) update.

JR and I did some work. Originally I was supposed to a bunch of things to my car, but I got lazy because I knew that I have to order some parts later and will be lifting the car back up.

Done on my car:
- Replaced springs from 650R/550F Hyperco to 560R (10k)/448F (8k) Swift springs. I had them forever, but was lazy
- Changed caster on Vorshlag camber plates back to the OE position in the center to accommodate the caster change from the Z4M FCABs. This in turn now increased the amount of positive camber I can have now. The shaft of the strut was hitting the sides and limited me to a minimum of only -2.4 deg.





On his car:
- Diagnosed the clunk that he's been hearing on his front suspension. Turned out it was a bad end link. The same one we tightened last time. Took both end links off. He will be ordering new adjustable ones.
- Replaced his front corner bulbs with stealth bulbs to get rid of the egg yolk.
- Upgraded his old fluted fog housings to the newer clear glass ones.

Then ordered parts I needed and took advantage of the "sale" FCP euro had. Not really much of a sale, but the couple of things I wanted were so might as well.

9/12 update.

I got my parts. Was super excited to see them and get them out of the way



Then as I was going through them to make sure everything is there. They didn't give me the transmission mount. Ok no problem, I can do that later. Then I check the FCABs…hmm they look the same. Maybe it's not side specific? Check pictures on FCP. God dammit, I have 2 of the same sides



Called them up to get this sorted out. In the mean time, I will install all the other pieces I got first.

9/13 update.

I attempted to work on the car. I didn't get much done. I wasted 3 hours, getting the car up, taking pictures, and browsing the forums Then spent like 40 mins hammering out my underbody brace. I contemplated on cleaning it, but got lazy. Then I decided to finally check to see where my oil leak was coming from. Yep, CCV. Inspected other parts of the car…motor mounts totally need replacing. All the bushings I'm about to replace are shot too.

I looked at the tires, I knew that there were really bad. But yeah, it's bad. I need to find some spares for now for sure just to get the car to EAS to get tires.





They look like that on all 4 corners lol

Oh I finally found that strut mount nut that I dropped like a year ago. Now I don't have to buy a new one sweet.



Took some pictures of the underbody of the car.





You see all that damage to the brace and exhaust? I have no idea it was. Seriously looks like guts and teeth





Here is the end result after I hammered the brace. Looks a lot better. I was too lazy to clean, so I will revisit this later. It can't go on until FCP euro gives me that other FCAB anyways.



Then I had to clean up because dinner plans. I was able to get started on the control arms. On the passenger side, it's like 90% off. I just need to use the pickle fork and sledge to separate inner balljoint. The driver's side is like 70% done. Need to pickle fork both the balljoints.



Yesterday.

Didn't get much done. I spent some time cleaning the oil pan while I was sitting under there thinking of what I was going to try to do.



Then attempted to take off the control arm on the driver's side. Basically gave up on that for now lol The angle that I need to be for the pickle fork to do it's thing in is made for like right-handers. I'm left handed



So I'm like **** this, go to the other side since it'll probably be easier for left-handers. Well…what do you know? Comes off easy as hell. I didn't even use PB Blaster at all on that side.

I'm upgrading the control arms to ZHP control arms.



Then I attempted to put in the one correct FCAB I have. Hammered it like 90% of the way, then had to clean up and leave for the day.

So close, yet so far…



Don't know if I'm continuing the work today. But i'm definitely taking tomorrow off because football.
__________________
I like to reply to threads with 0 posts




Have a lighting problem? Read this first:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
sillieidiot is offline   Reply With Quote
Old 09-21-2018, 02:58 AM   #213
sillieidiot
Registered User
 
Join Date: Sep 2004
Location: the OC
Posts: 32,585
My Ride: '06 AW 330ci
Send a message via AIM to sillieidiot
9/17 update.

My buddy Pat came by to give me a hand for a bit. Got the driver's side control arm off, quick and easy.



Then we attempted to continue hammering the Z4M FCAB that I had installed 90% of the way. That **** was not moving :angry: I hit it so hard with my mallet that I broke the mallet



After like 30 mins, we were like this, do something else. Went to do the tie rods. Everything went smoothly and easily. I didn't measure the tie rods like you were supposed to though. Just eyeballed it lol





Then went back to the FCAB. Decided to just take the new control arm off to see if we can just bang it outside of the car. It seems like it's even harder to do off the car and without a rubber mallet.

So that's it for the day. I'm going to buy a new mallet tomorrow and start over. I'm hoping that my other FCAB from FCP euro comes tomorrow that way I can get them both installed. Then I can finally put the car down.


9/18 update.

FCP euro, where the is my FCAB and transmission mount? Been like a week since I told them and it's still not here. Still have no tracking. They told me they sent an email with tracking, didn't get that. First time using them, not having a positive experience so far...

Anyhow, JR came by for a bit. We worked on changing out his corner bulbs because one side is dead already. That took like 30 mins or so.

Then we tried to put in the FCAB I had on. Didn't work. The wood just took way too much power out each hit. Then decided to go to Home Depot and buy a new rubber mallet. Bought the heaviest and most expensive one they had.



Came back and even with banging the **** out of it, didn't do anything. Seriously?! How the hell is it this hard? I know that when I was doing it before, it went it in not too bad. So I decided that I’m going to take it off and start over. Couldn't take it out by hammering. So went to AutoZone, returned the pickle forks and rented a 3-jaw puller.

Bushing came off easy. Then lubed it up with some quick detailer and bang the **** out of it. Went in way easier this time. So my original hypothesis was correct in that since the lubrication dried, that's why it was so hard to move. Good to know. Next time, finish the FCAB install in one sitting

Dam you POS bushing



Looks good though now that it's in.


JR then had to leave before he hit traffic on the way back home. Meanwhile I was sitting there deciding whether or not I should go in. Decided to do the steering coupler. It was way easier to do on the lift. Literally like a 5 minute job.

Old vs. New:



And that was it. No parts meant I couldn't do the other side. I could have taken off my exhaust to prepare for the transmission mount. But I didn't want to commit to doing it yet


Today's post that I quoted myself from a thread I started on a different forum.

Quote:
Originally Posted by sillieidiot View Post
Didn't know where to put the thread, so I put it here. Right now I am furious at them. Just woke up to a shipping label created email. Seriously?!

So I ordered on 9/7. Paid for shipping to get my parts faster. It arrives 9/12, that same day I check the contents. They gave me two FCABs of the same side and it's missing the transmission mount I ordered. I called them within the 30 mins I received the package and it was near end of day for them to let them know. CS person says that it will be expedited and shipped to me asap. So you would think it would come like in 2 days maybe a week tops right? Didn't get any email about tracking like they told me, emailed them. They keep telling me it's shipped already (which I know is BS cause where is my tracking?). Then today, which is 8 days later, they finally ship it (technically, didn't ship, only label created). WTF. So it's going to come next week? How does it take so long to process a **** up on their part? I don't even know why I paid for shipping then. The original reason was so that I could get it faster, but if it's going to come incorrectly and then get delivered correctly at the original "free shipping" delivery date.

Oh yeah, I contacted the FCP euro member that was here to see if he could help me. Couldn't help me and told me to email them. So what do you do? Just general questions and PR I'm assuming?

Honestly, I only paid more for FCP euro parts for the service. It wasn't about the lifetime warranty or anything. I care more about service support. It was highly rated here. I find it severely lacking. I guess they are only good if you get the right parts the first time and their easy warranty (which I haven't tried). None of my items are going to fail any time soon for that to happen anyways. And if you do need assistance, if you're not planning to start the project for like a month out, then you're fine.

So now, because this part is going to arrive next week or two in which I won't even be in town, I'm forced to go find/buy the part locally to get it installed.

edit:
Special order only part. Awesome. It'll come next week as well. If I knew it was going to take FCP this long, the dealerships could have gotten it to me like yesterday. Guess I'll just wait for the part to come in.
So yeah. I'm pretty much stuck cause I can't button the car up until the part comes in. Hoping it comes in earlier than next week.
__________________
I like to reply to threads with 0 posts




Have a lighting problem? Read this first:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
sillieidiot is offline   Reply With Quote
Old 09-24-2018, 03:38 PM   #214
sillieidiot
Registered User
 
Join Date: Sep 2004
Location: the OC
Posts: 32,585
My Ride: '06 AW 330ci
Send a message via AIM to sillieidiot
9/22 update.

OMG, the part arrived from FCP euro faster than I thought it would. I immediately checked to make sure it was the correct side that I needed. Cool perfect , the transmission mount was also there. Finally, I can finish up the car.

Since my car has been sitting on the lift for like over a week, there was quite a build up of air in the system. So when I went out, I wasn't able to lift the car up to the highest setting. Well I could, but I wasn't comfortable with doing so. It was on the first setting, so I just did everything there. I decided that I would forgo the transmission mounts for now because that requires taking off the exhaust. It would be easier on the highest setting. So I'll do it next time.

Putting the FCAB on was quick. Took like 2 mins tops. For the most part, the remaining bits that needed to go on didn't take long. Probably like an hour total to put on the control arm, under body brace, and the splash shield.

Last shot before I put the splash shield on.



It actually only took me longer because my tires were so bad, I went ahead and put on a couple spares I had. I moved the ARC-8 rears to the fronts which surprisingly had better life than the fronts for some reason. Then an M68 in the rear and an X5 spare wheel on the other side.





Today's update.

I spent some time to do some maintenance on my lift. Cleaned it a little. And bled it to get all the air out. Now it's back to full working condition. Good as new.

Last picture for the day. I raised the fronts up like 1 full turn. Don't think it made a difference.




I was originally set to buy new tires as well. But that timeline got pushed back due to this parts incident. I did contact EAS to see if they could get me anything today (I have to drop off my car on tomorrow). But if not, I'll just take it to Wayne's as is, and the tires can go on when I get the car back.

So with all these done, the car is ready for tires, then alignment. Technically, I need to do the RTABs (which I have sitting in a box somewhere). But I'm bundling that with my rear reinforcement at a later date.
__________________
I like to reply to threads with 0 posts




Have a lighting problem? Read this first:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
sillieidiot is offline   Reply With Quote
Old 09-25-2018, 10:11 AM   #215
jarjar
Registered User
 
Join Date: Jun 2016
Location: Toronto
Posts: 473
My Ride: 04 BMW 330CI
Great looking car. What reinforcement do you intend to do?
jarjar is offline   Reply With Quote
Old 09-26-2018, 12:36 AM   #216
sillieidiot
Registered User
 
Join Date: Sep 2004
Location: the OC
Posts: 32,585
My Ride: '06 AW 330ci
Send a message via AIM to sillieidiot
Quote:
Originally Posted by jarjar View Post
Great looking car. What reinforcement do you intend to do?
Thanks. I'm going with the Vincebar with the skins he makes with it. Pretty much just waiting on him to make the kit. I'm in no rush though lol I'm still debating on whether I will do the Mason X-brace on top of that or not. I might get lazy and just do the rear strut bar.
__________________
I like to reply to threads with 0 posts




Have a lighting problem? Read this first:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
sillieidiot is offline   Reply With Quote
Old 10-12-2018, 03:34 AM   #217
E46mike-izzle
Registered User
 
Join Date: Jun 2008
Location: Southern Cali
Posts: 787
My Ride: 330ci
@sillieidiot Please perform maintenance on my 14-year-old dinosaur! He currently suffers from having a cataract to his right eye. In addition, he needs your TLC from you. Thanks.
__________________
-Mike-

E46mike-izzle is offline   Reply With Quote
Old 10-13-2018, 10:31 PM   #218
sillieidiot
Registered User
 
Join Date: Sep 2004
Location: the OC
Posts: 32,585
My Ride: '06 AW 330ci
Send a message via AIM to sillieidiot
Quote:
Originally Posted by E46mike-izzle View Post
@sillieidiot Please perform maintenance on my 14-year-old dinosaur! He currently suffers from having a cataract to his right eye. In addition, he needs your TLC from you. Thanks.
lol why is that not fixed yet? I thought you sold your car. Maybe we'll do something in November when I get back from work. Your number still the same?
__________________
I like to reply to threads with 0 posts




Have a lighting problem? Read this first:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
sillieidiot is offline   Reply With Quote
Old 10-17-2018, 10:27 AM   #219
tuscan1205
Registered User
 
Join Date: Mar 2008
Location: SV, Arizona
Posts: 1,252
My Ride: e46 325CI, w212 E550
Quote:
Originally Posted by E46mike-izzle View Post
@sillieidiot Please perform maintenance on my 14-year-old dinosaur! He currently suffers from having a cataract to his right eye. In addition, he needs your TLC from you. Thanks.
If you still have the car, please post pictures. I remember when you first did that wide body kit years ago. Best e46 custom wide body imo
__________________



To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


'02 e46 325CI & '12 w212 E550

tuscan1205 is offline   Reply With Quote
Old 10-17-2018, 11:37 AM   #220
e46JAB
Registered User
 
Join Date: Jul 2005
Location: South Carolina
Posts: 1,964
My Ride: e46 m3, e60 m5
Quote:
Originally Posted by tuscan1205 View Post
If you still have the car, please post pictures. I remember when you first did that wide body kit years ago. Best e46 custom wide body imo
Me too! I just looked through his build thread again from a few years back.
__________________

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
e46JAB is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON



All times are GMT -5. The time now is 01:23 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
(c) 1999 - VerticalScope Inc. All rights reserved.