Few little things. - E46Fanatics E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 11-27-2017, 01:52 AM   #1
Beemadude
Registered User
 
Join Date: Nov 2017
Location: Central coast
Posts: 32
My Ride: 2002 e46
Few little things.

My left fog light seems alot dinner than the right.. not that I use them.

Also orange oil lights pops on and off even though oil level is fine. It is coming up for an oil change though so could it just be thick oil?
Beemadude is offline   Reply With Quote
Old 11-27-2017, 03:17 AM   #2
514BM
Registered User
 
Join Date: Oct 2016
Location: Canada
Posts: 243
My Ride: '02 325ci
If the yellow oil light comes on at start up and goes away after a few seconds, your oil level sensor needs to be replaced.
If it comes on when you shut off the car, it means you need to add a bit of oil.
514BM is offline   Reply With Quote
Old 11-27-2017, 03:18 AM   #3
Beemadude
Registered User
 
Join Date: Nov 2017
Location: Central coast
Posts: 32
My Ride: 2002 e46
Oh cool thanks ?
Beemadude is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 11-27-2017, 07:18 PM   #4
Beemadude
Registered User
 
Join Date: Nov 2017
Location: Central coast
Posts: 32
My Ride: 2002 e46
Twice it has om e off after I've turned the car off. If I turn it on then turn it of again it goes away.

Only once it came on and went away after a few mins while driving so I topped up the oil and it hasn't come on since. It is coming due for an oil change though
Beemadude is offline   Reply With Quote
Old 11-27-2017, 07:19 PM   #5
RangerDave
Registered User
 
Join Date: Aug 2007
Location: Willamette Valley, Oregon
Posts: 1,880
My Ride: '00 328i ZSP w/ 254k
Year: 2000
Model: 328i
Transmission: 5MT
Quote:
Originally Posted by 514BM View Post
If the yellow oil light comes on at start up and goes away after a few seconds, your oil level sensor needs to be replaced.
If it comes on when you shut off the car, it means you need to add a bit of oil.
Sorry, but this info is incorrect. Also, your oil light is not coming on because of "thick oil".

If the yellow light comes on at start up and goes away after a few seconds, THIS IS COMPLETELY NORMAL. DO NOTHING.

I have never heard of it coming on as you shut off the car.

If the yellow light comes on while driving, the oil level could be low.

If it comes on while driving but goes away sometimes and oil level is fine, the sensor is bad and needs to be replaced (sensor is named Oil Level Sender).

If the RED oil light comes on while driving, the oil level may be extremely low, or your oil pump may have stopped working, or your RPMs may be too low, or you have some other (likely major) problem.


As far as your fog lights go, I would bet that one of the bulbs has been replaced with a different brand, OR one of the bulbs is about to die.
__________________

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

BMW - Honda - Jeep






To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
RangerDave is offline   Reply With Quote
Old 11-27-2017, 07:31 PM   #6
RangerDave
Registered User
 
Join Date: Aug 2007
Location: Willamette Valley, Oregon
Posts: 1,880
My Ride: '00 328i ZSP w/ 254k
Year: 2000
Model: 328i
Transmission: 5MT
Quote:
Originally Posted by Beemadude View Post
Twice it has om e off after I've turned the car off. If I turn it on then turn it of again it goes away.
I just did a quick search on this and it sounds like it could be from a low oil level as well but I didn't find a definitive answer. If your oil level is topped off, I would try replacing the sensor. They cost around $60.
__________________

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

BMW - Honda - Jeep






To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
RangerDave is offline   Reply With Quote
Old 11-27-2017, 07:33 PM   #7
Beemadude
Registered User
 
Join Date: Nov 2017
Location: Central coast
Posts: 32
My Ride: 2002 e46
Sweet thanks dude
Beemadude is offline   Reply With Quote
Old 11-27-2017, 09:07 PM   #8
armenh7
Registered User
 
Join Date: Dec 2016
Location: California
Posts: 8,552
My Ride: 2002 325i
Quote:
Originally Posted by RangerDave View Post
Sorry, but this info is incorrect. Also, your oil light is not coming on because of "thick oil".

If the yellow light comes on at start up and goes away after a few seconds, THIS IS COMPLETELY NORMAL. DO NOTHING.

I have never heard of it coming on as you shut off the car.

If the yellow light comes on while driving, the oil level could be low.

If it comes on while driving but goes away sometimes and oil level is fine, the sensor is bad and needs to be replaced (sensor is named Oil Level Sender).

If the RED oil light comes on while driving, the oil level may be extremely low, or your oil pump may have stopped working, or your RPMs may be too low, or you have some other (likely major) problem.


As far as your fog lights go, I would bet that one of the bulbs has been replaced with a different brand, OR one of the bulbs is about to die.
Wrong wrong wrong wrong wrong!!!
When the yellow oil light comes on for 30 seconds when starting the car, the oil level sensor is faulty.
When the yellow light comes on after you turn off the car, the oil is low.
armenh7 is offline   Reply With Quote
Old 11-28-2017, 01:45 AM   #9
514BM
Registered User
 
Join Date: Oct 2016
Location: Canada
Posts: 243
My Ride: '02 325ci
Quote:
Originally Posted by RangerDave View Post
Sorry, but this info is incorrect. Also, your oil light is not coming on because of "thick oil".

If the yellow light comes on at start up and goes away after a few seconds, THIS IS COMPLETELY NORMAL. DO NOTHING.

I have never heard of it coming on as you shut off the car.

If the yellow light comes on while driving, the oil level could be low.

If it comes on while driving but goes away sometimes and oil level is fine, the sensor is bad and needs to be replaced (sensor is named Oil Level Sender).

If the RED oil light comes on while driving, the oil level may be extremely low, or your oil pump may have stopped working, or your RPMs may be too low, or you have some other (likely major) problem.


As far as your fog lights go, I would bet that one of the bulbs has been replaced with a different brand, OR one of the bulbs is about to die.
Man I know you are trying to help him out but please don't say someone else's info is incorrect when you obviously have no clue of what you are talking about. OP if you ever encounter a red oil light while driving, immediately stop the car.

Last edited by 514BM; 11-28-2017 at 01:45 AM.
514BM is offline   Reply With Quote
Old 11-28-2017, 01:50 AM   #10
514BM
Registered User
 
Join Date: Oct 2016
Location: Canada
Posts: 243
My Ride: '02 325ci
Quote:
Originally Posted by RangerDave View Post
I have never heard of it coming on as you shut off the car.
Yeah this is due to the fact that your sensor is not working and you find it ''normal'' to have a yellow oil light for 30 secs when you start your car.
514BM is offline   Reply With Quote
Old 11-28-2017, 05:48 AM   #11
RayPooley
Registered User
 
Join Date: Jul 2012
Location: Liverpool
Posts: 3,767
My Ride: 320i SE Coupe
Quote:
Originally Posted by Beemadude View Post
My left fog light seems alot dinner than the right.. not that I use them.

Also orange oil lights pops on and off even though oil level is fine. It is coming up for an oil change though so could it just be thick oil?
Some good advice. Check your oil once a week using the dipstick. on level ground when the engine is cold. top up as needed. If you do that routinely you should neve have to see that light again. Don't rely on the level sensor.

The dim light is probably a loose or corroded terminal. Just find it, pull it apart and check for water ingress or oxidation build up on the pins. Clean it up and reseat it if possible otherwise replace the terminal block.

Last edited by RayPooley; 11-28-2017 at 05:51 AM.
RayPooley is online now   Reply With Quote
Old 11-28-2017, 05:50 AM   #12
Beemadude
Registered User
 
Join Date: Nov 2017
Location: Central coast
Posts: 32
My Ride: 2002 e46
Cool.. thanks dude!
Beemadude is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON



All times are GMT -5. The time now is 08:44 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
(c) 1999 - VerticalScope Inc. All rights reserved.