DIY E46 Media Centre: MP3, videos, Digital Radio, Digital TV? - Page 7 - E46Fanatics E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Go Back   E46Fanatics > Tuning & Tech > Mobile Electronics Forum

Mobile Electronics Forum
Have all your A/V and electronics questions answered here. Ipods, A/V, Radar Detectors Oh My!

Reply
 
Thread Tools Search this Thread Rating: Thread Rating: 69 votes, 4.99 average. Display Modes
Old 12-01-2013, 06:54 PM   #121
E46 Coupe
Registered User
 
E46 Coupe's Avatar
 
Join Date: May 2008
Location: Australia
Posts: 5,273
My Ride: Rules1 & 2: S T F U!
ETA on next batch Pete?
__________________

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
E46 Coupe is offline   Reply With Quote
Old 12-02-2013, 08:31 PM   #122
bgennette
Registered User
 
Join Date: May 2013
Location: Newcastle AU
Posts: 10
My Ride: l322 Range Rover
Incompatibility with L322

There must be some command differences in the L322 Range Rover's iBus command set. When it is plugged in the PiBus 2 starts flickering its LED at 1Hz and the Raspberry Pi activity LED flickers for ~30s as it boots up, BUT
CDC does not appear on the MODE screen
Something in the Radio or Video or Amplifier module gets turned on and draws >3A continually until the battery is disconnected to reset it.

Will experiment some more this weekend with a Nav Coder plugged in to capture the messages exchanged.

bye.
bgennette is offline   Reply With Quote
Old 12-03-2013, 02:34 AM   #123
PeteAU
Registered User
 
Join Date: Oct 2011
Location: Melbourne
Posts: 541
My Ride: 330i
Quote:
Originally Posted by bgennette View Post
There must be some command differences in the L322 Range Rover's iBus command set. When it is plugged in the PiBus 2 starts flickering its LED at 1Hz and the Raspberry Pi activity LED flickers for ~30s as it boots up, BUT
CDC does not appear on the MODE screen
Something in the Radio or Video or Amplifier module gets turned on and draws >3A continually until the battery is disconnected to reset it.

Will experiment some more this weekend with a Nav Coder plugged in to capture the messages exchanged.

bye.
The Pi creates a log file: /storage/ibus.txt, do you know how to read it? Have a look at it, or email it to me. It should tell us if there's a problem with your ibus circuitry, or that the BMW/Rover messages are really different.
PeteAU is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-12-2013, 02:41 AM   #124
anto
Registered User
 
Join Date: Dec 2013
Location: FR
Posts: 37
My Ride: M3 E46 SMG
Hi,

I'm really interested in your work.

I firstly want to congratulate you for the accomplished work. It's really impressive.

I want, of course, to buy you a card. Can you tell me when you'll be ready to deliver ?

Thks 4 all this work
anto is offline   Reply With Quote
Old 12-13-2013, 03:26 AM   #125
Arthur530SE
Registered User
 
Join Date: Nov 2013
Location: Burton on Trent, U.K
Posts: 79
My Ride: 2001 530iSE
Hi,

I have an enquiry

The pibus and RPi are working fine in my car, but I can't find the iBus.txt file in /storage/ which on my setup is on my EXT4 USB stick.

How is this file generated?
Is it the pibus software or the ATtiny chip that generates this file?
Does this file only get generated if there is a problem?
Could it be the way my OpenELEC installation is setup? (using a separate EXT4 USB stick)

This is confusing me as to where the file is. I'm fairly new to Linux so any help would be greatly appreciated.

Cheers
Arthur530SE is offline   Reply With Quote
Old 12-13-2013, 03:47 AM   #126
anto
Registered User
 
Join Date: Dec 2013
Location: FR
Posts: 37
My Ride: M3 E46 SMG
Hi,

I'm actually having a look at Pete's work .

It's the Pi which writes the ibus.txt file. You 'll find all usages in ibus.c file.
anto is offline   Reply With Quote
Old 12-13-2013, 10:55 AM   #127
Arthur530SE
Registered User
 
Join Date: Nov 2013
Location: Burton on Trent, U.K
Posts: 79
My Ride: 2001 530iSE
Quote:
Originally Posted by anto View Post
Hi,

I'm actually having a look at Pete's work .

It's the Pi which writes the ibus.txt file. You 'll find all usages in ibus.c file.
Hi Anto,

Thank for the info I'll take a look.
Arthur530SE is offline   Reply With Quote
Old 12-22-2013, 04:27 AM   #128
PeteAU
Registered User
 
Join Date: Oct 2011
Location: Melbourne
Posts: 541
My Ride: 330i
Quote:
Originally Posted by E46 Coupe View Post
ETA on next batch Pete?
About two weeks.

Quote:
Originally Posted by Arthur530SE View Post
Hi,

I have an enquiry

The pibus and RPi are working fine in my car, but I can't find the iBus.txt file in /storage/ which on my setup is on my EXT4 USB stick.

How is this file generated?
Is it the pibus software or the ATtiny chip that generates this file?
Does this file only get generated if there is a problem?
Could it be the way my OpenELEC installation is setup? (using a separate EXT4 USB stick)

This is confusing me as to where the file is. I'm fairly new to Linux so any help would be greatly appreciated.

Cheers
It logs all the time, not just when there's errors, it should be there: ibus.txt in lowercase. But I don't think Windows can read the EXT4 storage partition.

In the long run you might want to disable the logging, so your flash memory doesn't wear out. You can do that from the shell on the Pi:
Code:
cd /storage/
rm ibus.txt
ln -s /dev/null ibus.txt
reboot
PeteAU is offline   Reply With Quote
Old 12-23-2013, 01:51 AM   #129
E46 Coupe
Registered User
 
E46 Coupe's Avatar
 
Join Date: May 2008
Location: Australia
Posts: 5,273
My Ride: Rules1 & 2: S T F U!
DIY E46 Media Centre: MP3, videos, Digital Radio, Digital TV?

Thanks Pete for the effort you're putting in! Can't wait till you have the parts for the next batch


Sent from BimmerApp mobile app
__________________

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
E46 Coupe is offline   Reply With Quote
Old 01-03-2014, 02:33 AM   #130
94vtirozguy
Registered User
 
Join Date: Jan 2013
Location: Australia
Posts: 69
My Ride: 330 ci convertible
Quote:
Originally Posted by ppmz View Post
About two weeks.



It logs all the time, not just when there's errors, it should be there: ibus.txt in lowercase. But I don't think Windows can read the EXT4 storage partition.

In the long run you might want to disable the logging, so your flash memory doesn't wear out. You can do that from the shell on the Pi:
Code:
cd /storage/
rm ibus.txt
ln -s /dev/null ibus.txt
reboot
there are apps around that will allow windows to view the above partitions.
94vtirozguy is offline   Reply With Quote
Old 01-08-2014, 03:14 AM   #131
E46 Coupe
Registered User
 
E46 Coupe's Avatar
 
Join Date: May 2008
Location: Australia
Posts: 5,273
My Ride: Rules1 & 2: S T F U!
Got the kit today (super fast postage!)
Did some research and got myself a promising SD card.
Started soldering (all parts are accounted for)
Just waiting for my RPi
Thanks Pete!


Sent from BimmerApp mobile app
__________________

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
E46 Coupe is offline   Reply With Quote
Old 01-08-2014, 06:04 PM   #132
E46 Coupe
Registered User
 
E46 Coupe's Avatar
 
Join Date: May 2008
Location: Australia
Posts: 5,273
My Ride: Rules1 & 2: S T F U!
Quote:
Originally Posted by PeteAU View Post
The hardware has power even if you lock the car, just gotta add some software that gracefully shuts down after ~5 mins of inactivity.
Pete, was the shutdown solution implemented?
__________________

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
E46 Coupe is offline   Reply With Quote
Old 01-08-2014, 06:24 PM   #133
PeteAU
Registered User
 
Join Date: Oct 2011
Location: Melbourne
Posts: 541
My Ride: 330i
Quote:
Originally Posted by E46 Coupe View Post
Got the kit today (super fast postage!)
Did some research and got myself a promising SD card.
Started soldering (all parts are accounted for)
Just waiting for my RPi
Thanks Pete!
Model A or B? I noticed they got more expensive, must be our weak AUD$. If you ordered from Element 14 and they're in stock you'll probably get it in 24 hours, they (E14) are awesome.

Quote:
Originally Posted by E46 Coupe View Post
Pete, was the shutdown solution implemented?
Yeah, I'm not entirely happy with the shutdown strategy but it works like this:

* The pibus software on the Pi watches the IBUS for idleness. If there's 4 minutes of no ibus messages, it runs /sbin/shutdown.
* The ATtiny firmware watches the IBUS for idleness as well. If there's 6 minutes of no ibus messages, it cuts the Pi's power supply.
PeteAU is offline   Reply With Quote
Old 01-08-2014, 06:49 PM   #134
E46 Coupe
Registered User
 
E46 Coupe's Avatar
 
Join Date: May 2008
Location: Australia
Posts: 5,273
My Ride: Rules1 & 2: S T F U!
Quote:
Originally Posted by PeteAU View Post
Model A or B? I noticed they got more expensive, must be our weak AUD$. If you ordered from Element 14 and they're in stock you'll probably get it in 24 hours, they (E14) are awesome.
Got the model B - they have free shipping for orders $45+ so I got the WiPi adaptor (difference working out to be $5 more than just the model B and shipping)
They have just confirmed that they are sending it out today


Quote:
Originally Posted by PeteAU View Post
Yeah, I'm not entirely happy with the shutdown strategy but it works like this:

* The pibus software on the Pi watches the IBUS for idleness. If there's 4 minutes of no ibus messages, it runs /sbin/shutdown.
* The ATtiny firmware watches the IBUS for idleness as well. If there's 6 minutes of no ibus messages, it cuts the Pi's power supply.
__________________

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
E46 Coupe is offline   Reply With Quote
Old 01-08-2014, 08:05 PM   #135
headlock
Registered User
 
Join Date: Jul 2012
Location: Adelaide
Posts: 121
My Ride: E46 M3
First of all, brilliant work on this.

RPi is in the mail and I'm going to order the kit next week on payday

just need to teach myself how to solder PCB now lol. Be nice if there was an easy way to integrate nav into this somehow. My car is non nav, i know of a few Rpi GPS solutions but not via open elec. Might be something to play with

Last edited by headlock; 01-08-2014 at 08:06 PM.
headlock is offline   Reply With Quote
Old 01-10-2014, 03:02 AM   #136
E46 Coupe
Registered User
 
E46 Coupe's Avatar
 
Join Date: May 2008
Location: Australia
Posts: 5,273
My Ride: Rules1 & 2: S T F U!
Got my RPi today!
Have the OS sorted and testing on TV now.
Skin looks great Pete!
Will put it all together and into the car tomorrow
__________________

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
E46 Coupe is offline   Reply With Quote
Old 01-10-2014, 09:11 PM   #137
E46 Coupe
Registered User
 
E46 Coupe's Avatar
 
Join Date: May 2008
Location: Australia
Posts: 5,273
My Ride: Rules1 & 2: S T F U!
Quote:
Originally Posted by bgennette View Post
There must be some command differences in the L322 Range Rover's iBus command set. When it is plugged in the PiBus 2 starts flickering its LED at 1Hz and the Raspberry Pi activity LED flickers for ~30s as it boots up, BUT
CDC does not appear on the MODE screen
Something in the Radio or Video or Amplifier module gets turned on and draws >3A continually until the battery is disconnected to reset it.

Will experiment some more this weekend with a Nav Coder plugged in to capture the messages exchanged.

bye.
I've just put it all in and am having no CDC recognised on the headunit.
Did you work out what happened bgennette?


Sent from BimmerApp mobile app
__________________

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
E46 Coupe is offline   Reply With Quote
Old 01-10-2014, 09:21 PM   #138
PeteAU
Registered User
 
Join Date: Oct 2011
Location: Melbourne
Posts: 541
My Ride: 330i
Quote:
Originally Posted by E46 Coupe View Post
I've just put it all in and am having no CDC recognised on the headunit.
Did you work out what happened bgennette?
Does the Phone button do something?

Can you get a shell prompt on the Pi? e.g. via ethernet cable or WiFi.

I would look at this file:

Code:
cat ~/.config/autostart.sh
ls -l ~/.config/autostart.sh
If the x (executable) flag isn't set, set it:

Code:
chmod +x ~/.config/autostart.sh
Then reboot it and see if pibus gets automatically started:

Code:
ps aux |grep pibus
If it's running but still no CDC, send me your ibus.txt log file.
PeteAU is offline   Reply With Quote
Old 01-10-2014, 09:47 PM   #139
E46 Coupe
Registered User
 
E46 Coupe's Avatar
 
Join Date: May 2008
Location: Australia
Posts: 5,273
My Ride: Rules1 & 2: S T F U!
Thanks Pete!

Phone button acts "normal" as in redials the last number on my phone via BT

I disabled the ibus.txt file.. How do I re-enable it? (Linux newb)


Sent from BimmerApp mobile app
__________________

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
E46 Coupe is offline   Reply With Quote
Old 01-10-2014, 11:26 PM   #140
PeteAU
Registered User
 
Join Date: Oct 2011
Location: Melbourne
Posts: 541
My Ride: 330i
Quote:
Originally Posted by E46 Coupe View Post
Thanks Pete!

Phone button acts "normal" as in redials the last number on my phone via BT

I disabled the ibus.txt file.. How do I re-enable it? (Linux newb)
Code:
cd /storage
rm ibus.txt
reboot
PeteAU is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON



All times are GMT -5. The time now is 09:28 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
(c) 1999 - VerticalScope Inc. All rights reserved.