DIY E46 Media Centre: MP3, videos, Digital Radio, Digital TV? - Page 8 - E46Fanatics E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Go Back   E46Fanatics > Tuning & Tech > Mobile Electronics Forum

Mobile Electronics Forum
Have all your A/V and electronics questions answered here. Ipods, A/V, Radar Detectors Oh My!

Reply
 
Thread Tools Search this Thread Rating: Thread Rating: 69 votes, 4.99 average. Display Modes
Old 01-10-2014, 11:37 PM   #141
E46 Coupe
Registered User
 
E46 Coupe's Avatar
 
Join Date: May 2008
Location: Australia
Posts: 5,273
My Ride: Rules1 & 2: S T F U!
Haha. Thanks Pete I worked it out.
Found the issue with the help of Netgun.. He's being the penguin trainer here atm.
Will tell you how it goes soon.


Sent from BimmerApp mobile app
__________________

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
E46 Coupe is offline   Reply With Quote
Old 01-11-2014, 12:56 AM   #142
E46 Coupe
Registered User
 
E46 Coupe's Avatar
 
Join Date: May 2008
Location: Australia
Posts: 5,273
My Ride: Rules1 & 2: S T F U!
All working now. It was the pibus not executing properly.
Thanks Pete!

Definitely recommend the pibus by Pete.


Sent from BimmerApp mobile app
__________________

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
E46 Coupe is offline   Reply With Quote
Old 01-11-2014, 01:01 AM   #143
PeteAU
Registered User
 
Join Date: Oct 2011
Location: Melbourne
Posts: 541
My Ride: 330i
Quote:
Originally Posted by E46 Coupe View Post
All working now. It was the pibus not executing properly.
Thanks Pete!

Definitely recommend the pibus by Pete.
Ok, what was it, +x flag or something else? It seems a few people have stumbled at the "no CDC" stage.

BTW It might need a software update for bluetooth, since I use the Phone & Speak buttons which might interfere with your call features.
PeteAU is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-11-2014, 02:58 AM   #144
E46 Coupe
Registered User
 
E46 Coupe's Avatar
 
Join Date: May 2008
Location: Australia
Posts: 5,273
My Ride: Rules1 & 2: S T F U!
Mainly I had extracted the zip package retaining the directory structure and followed the instructions for the autostart.sh
Thus pointing to the wrong place. Plus needing to set the pibus to eXec.
I'd mainly use the screen in NAV mode with music in background, I haven't tried to see if the phone button is affected outside of CDC, would be disappointing if it is... I'll report back


Sent from BimmerApp mobile app
__________________

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
E46 Coupe is offline   Reply With Quote
Old 01-11-2014, 05:35 PM   #145
E46 Coupe
Registered User
 
E46 Coupe's Avatar
 
Join Date: May 2008
Location: Australia
Posts: 5,273
My Ride: Rules1 & 2: S T F U!
Had a play and the phone button answers and dials etc but causes the headunit to "switch" screens twice.
(Though it works it's an annoyance)

Also found the pibus is keeping the car "awake"
While the pibus itself isn't going into standby (led flash @ 1hz) it's keeping my nav unit and amp on.


Sent from BimmerApp mobile app
__________________

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
E46 Coupe is offline   Reply With Quote
Old 01-11-2014, 06:42 PM   #146
PeteAU
Registered User
 
Join Date: Oct 2011
Location: Melbourne
Posts: 541
My Ride: 330i
Quote:
Originally Posted by E46 Coupe View Post
Had a play and the phone button answers and dials etc but causes the headunit to "switch" screens twice.
(Though it works it's an annoyance)
There's a beta release here which should fix that for you, but I haven't tested it yet: http://pibus.info/download_beta.html

Quote:
Originally Posted by E46 Coupe View Post
Also found the pibus is keeping the car "awake"
While the pibus itself isn't going into standby (led flash @ 1hz) it's keeping my nav unit and amp on.
Really? I just tried it with the key out, doors closed, boot open, and it all shut down (including nav) after 6 minutes. Are you testing with a door open, or SD card removed?

Email me the ibus.txt log after about 7 minutes, something must be chattering away still.
PeteAU is offline   Reply With Quote
Old 01-11-2014, 06:48 PM   #147
E46 Coupe
Registered User
 
E46 Coupe's Avatar
 
Join Date: May 2008
Location: Australia
Posts: 5,273
My Ride: Rules1 & 2: S T F U!
Quote:
Originally Posted by PeteAU View Post
There's a beta release here which should fix that for you, but I haven't tested it yet: http://pibus.info/download_beta.html



Really? I just tried it with the key out, doors closed, boot open, and it all shut down (including nav) after 6 minutes. Are you testing with a door open, or SD card removed?

Email me the ibus.txt log after about 7 minutes, something must be chattering away still.
Fantastic, I'll try out the new beta pibus.

The non shutdown was caused by Openelec's script to poll the NTP servers for time every 30 seconds:
Quote:
Originally Posted by wiki.openelec.tv
Setting the time correctly:
Raspberry PI does not come with a real clock. What that means is that you will have to set the time every-time you boot by hand. But, there is an easy way to rectify this:
  • ssh to OpenElec. (u:root/p:openelec)
  • "vi /storage/.config/autostart.sh"
  • Add the following content:

#!/bin/sh (sleep 30; \ /usr/sbin/ntpdate pool.ntp.org; \ )&
  • "chmod +x /storage/.config/autostart.sh"
When your PI comes up, it will take 30 seconds and the time will be in sync.
I just removed it and it now goes into standby

Must say your support on a lot of my fails are much appreciated
__________________

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
E46 Coupe is offline   Reply With Quote
Old 01-11-2014, 06:53 PM   #148
E46 Coupe
Registered User
 
E46 Coupe's Avatar
 
Join Date: May 2008
Location: Australia
Posts: 5,273
My Ride: Rules1 & 2: S T F U!
It's keeping the car awake again.

Basically it works (once) after rebooting the rpi.

  1. reboot
  2. after 4 minutes nav and rpi go into standby (car unlocked)
  3. unlocking car via remote wakes the nav and rpi
  4. BMW logo no longer displayed on screen upon door open (not really fussed)
  5. turn on ignition
  6. headunit can show CDC (xbmc)
    tried 2 options: 1- playing and stopping mp3, 2- not do anything in xbmc
  7. turn off ignition
  8. lock car
  9. wait 10 minutes
  10. nav unit and rpi still on - does not go into standyby (continues to stay awake.. forever - good thing I have a battery tender)
  11. console [reboot]: repeat from 2.
Emailing you my ibus.txt now Pete. I suspect the pibus needs to ignore the messages coming from the NAV unit, though it works properly when the rpi is rebooted. (I dunno )

PS. the speak button does pause xbmc but also starts a call on the phone lol
__________________

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Last edited by E46 Coupe; 01-11-2014 at 09:53 PM.
E46 Coupe is offline   Reply With Quote
Old 01-12-2014, 03:18 AM   #149
PeteAU
Registered User
 
Join Date: Oct 2011
Location: Melbourne
Posts: 541
My Ride: 330i
Quote:
Originally Posted by E46 Coupe View Post
It's keeping the car awake again.

Basically it works (once) after rebooting the rpi.

  1. reboot
  2. after 4 minutes nav and rpi go into standby (car unlocked)
  3. unlocking car via remote wakes the nav and rpi
  4. BMW logo no longer displayed on screen upon door open (not really fussed)
  5. turn on ignition
  6. headunit can show CDC (xbmc)
    tried 2 options: 1- playing and stopping mp3, 2- not do anything in xbmc
  7. turn off ignition
  8. lock car
  9. wait 10 minutes
  10. nav unit and rpi still on - does not go into standyby (continues to stay awake.. forever - good thing I have a battery tender)
  11. console [reboot]: repeat from 2.
Emailing you my ibus.txt now Pete. I suspect the pibus needs to ignore the messages coming from the NAV unit, though it works properly when the rpi is rebooted. (I dunno )

PS. the speak button does pause xbmc but also starts a call on the phone lol
Ah huh. I think I see what's happening in your log. The CDC (Pi) keeps announcing itself, but your radio never replies (mine does). Or maybe it replies only once when you 1st booted it.

Anyway, I changed the logic a bit, so try the new version on the _beta page, hopefully will fix it. It now stops the whole polling thing if there's a cdc-info request from the radio.

Quote:
Originally Posted by E46 Coupe View Post
PS. the speak button does pause xbmc but also starts a call on the phone lol
Is that good or bad?
PeteAU is offline   Reply With Quote
Old 01-12-2014, 03:25 AM   #150
E46 Coupe
Registered User
 
E46 Coupe's Avatar
 
Join Date: May 2008
Location: Australia
Posts: 5,273
My Ride: Rules1 & 2: S T F U!
Quote:
Originally Posted by PeteAU View Post
Ah huh. I think I see what's happening in your log. The CDC (Pi) keeps announcing itself, but your radio never replies (mine does). Or maybe it replies only once when you 1st booted it.

Anyway, I changed the logic a bit, so try the new version on the _beta page, hopefully will fix it. It now stops the whole polling thing if there's a cdc-info request from the radio.



Is that good or bad?
I'll try it now. Pete your are a legend for being so patient!

The speak button is partial but resting on bad.


Sent from BimmerApp mobile app
__________________

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
E46 Coupe is offline   Reply With Quote
Old 01-12-2014, 03:36 AM   #151
E46 Coupe
Registered User
 
E46 Coupe's Avatar
 
Join Date: May 2008
Location: Australia
Posts: 5,273
My Ride: Rules1 & 2: S T F U!
I'm presuming the pibus-20140112.zip? Had to hot link, guess you're doing it on the fly and didn't update the _beta page?
much appreciated Pete!
__________________

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
E46 Coupe is offline   Reply With Quote
Old 01-12-2014, 04:37 AM   #152
E46 Coupe
Registered User
 
E46 Coupe's Avatar
 
Join Date: May 2008
Location: Australia
Posts: 5,273
My Ride: Rules1 & 2: S T F U!
YOUUU BEAUTYYY!!
Your beta worked Pete! I couldn't be happier.
Nav and amp shuts down like normal now and the rpi turns off 6 minites after the nav drive does it's thing (11 minutes odd)
Email sent (will attempt to drop off something for your support!)


Sent from BimmerApp mobile app
__________________

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
E46 Coupe is offline   Reply With Quote
Old 01-12-2014, 05:05 AM   #153
E46 Coupe
Registered User
 
E46 Coupe's Avatar
 
Join Date: May 2008
Location: Australia
Posts: 5,273
My Ride: Rules1 & 2: S T F U!
Andddd for some reason I can't catch a break I just checked the car and the nav unit + rpi has woken up again...

Emailing ibus.txt...

Sorry Pete.
__________________

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Last edited by E46 Coupe; 01-12-2014 at 05:15 AM.
E46 Coupe is offline   Reply With Quote
Old 01-19-2014, 03:34 PM   #154
E46 Coupe
Registered User
 
E46 Coupe's Avatar
 
Join Date: May 2008
Location: Australia
Posts: 5,273
My Ride: Rules1 & 2: S T F U!
Latest beta is working fine now Pete, thanks for that!
__________________

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
E46 Coupe is offline   Reply With Quote
Old 01-19-2014, 05:36 PM   #155
anto
Registered User
 
Join Date: Dec 2013
Location: FR
Posts: 37
My Ride: M3 E46 SMG
Hi Pete,

I'm actually installing the Pibus I bought you in my car. I want to update the attiny with your latest program but I'm not familiar with that process. Can you please explain me how to do this in a Few words ? Thks in advance.

Last edited by anto; 01-20-2014 at 03:44 AM.
anto is offline   Reply With Quote
Old 01-20-2014, 04:33 AM   #156
PeteAU
Registered User
 
Join Date: Oct 2011
Location: Melbourne
Posts: 541
My Ride: 330i
Quote:
Originally Posted by anto View Post
Hi Pete,

I'm actually installing the Pibus I bought you in my car. I want to update the attiny with your latest program but I'm not familiar with that process. Can you please explain me how to do this in a Few words ? Thks in advance.
There's actually nothing new for the ATtiny, you should be fully up to date. There's just an update for the /storage/pibus program on the R-Pi though. Do you know how to install that?
PeteAU is offline   Reply With Quote
Old 01-20-2014, 08:51 AM   #157
anto
Registered User
 
Join Date: Dec 2013
Location: FR
Posts: 37
My Ride: M3 E46 SMG
Hi,

In ibus.c, i've seen

#define SETTING_NO_PHONE_BUTTON 1 /* For cars with factory bluetooth */
#define SETTING_NO_CAMERA 2 /* Don't switch to camera on 'R' gear */
#define SETTING_NO_CDC 4 /* Don't switch video on CDC on/off */
#define SETTING_NO_IDLE_TIMEOUT 8 /* Don't power off PI after 6 minutes */

to deal with car's options.

Was it present in the version you shipped to me ?
anto is offline   Reply With Quote
Old 01-21-2014, 06:20 AM   #158
PeteAU
Registered User
 
Join Date: Oct 2011
Location: Melbourne
Posts: 541
My Ride: 330i
Quote:
Originally Posted by anto View Post
Hi,

In ibus.c, i've seen

#define SETTING_NO_PHONE_BUTTON 1 /* For cars with factory bluetooth */
#define SETTING_NO_CAMERA 2 /* Don't switch to camera on 'R' gear */
#define SETTING_NO_CDC 4 /* Don't switch video on CDC on/off */
#define SETTING_NO_IDLE_TIMEOUT 8 /* Don't power off PI after 6 minutes */

to deal with car's options.

Was it present in the version you shipped to me ?
Yep, every shipped unit already has that. I foresaw the need.
PeteAU is offline   Reply With Quote
Old 01-21-2014, 08:40 AM   #159
anto
Registered User
 
Join Date: Dec 2013
Location: FR
Posts: 37
My Ride: M3 E46 SMG
Ok,

Thks 4 all
anto is offline   Reply With Quote
Old 01-23-2014, 09:31 PM   #160
E46 Coupe
Registered User
 
E46 Coupe's Avatar
 
Join Date: May 2008
Location: Australia
Posts: 5,273
My Ride: Rules1 & 2: S T F U!
FYI Pete the -r argument switches to the external camera input on both 20140113 and 20140113


Sent from BimmerApp mobile app
__________________

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
E46 Coupe is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON



All times are GMT -5. The time now is 03:12 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
(c) 1999 - VerticalScope Inc. All rights reserved.