DIY E46 Media Centre: MP3, videos, Digital Radio, Digital TV? - Page 53 - E46Fanatics E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Go Back   E46Fanatics > Tuning & Tech > Mobile Electronics Forum

Mobile Electronics Forum
Have all your A/V and electronics questions answered here. Ipods, A/V, Radar Detectors Oh My!

Reply
 
Thread Tools Search this Thread Rating: Thread Rating: 69 votes, 4.99 average. Display Modes
Old 03-17-2016, 02:01 AM   #1041
PeteAU
Registered User
 
Join Date: Oct 2011
Location: Melbourne
Posts: 541
My Ride: 330i
Quote:
Originally Posted by donis86 View Post
You were right! My Pi's composite video is not working.Thank you for help. Before I buy new Pi can you confirm that using HDMI--->RCA'----> TRRS cable conversion will not solve my problem? If so should I stick with Pi2 or should I get Pi3 (I saw that some guys on this forum is working on Pi3 to work with pibus).
I guess the 2.5V regulator on the Pi burnt out.

You can use that box, it looks big & messy though.

Pi3 works OK for me, it's a little faster at 1.2GHz. But I didn't test it for long yet.
PeteAU is offline   Reply With Quote
Old 03-17-2016, 02:04 AM   #1042
miikew
Registered User
 
Join Date: Sep 2015
Location: Poland
Posts: 33
My Ride: X3 E83
anyone working on plugin for kodi to read cardata from cheap bluetooth ELM327 module ? maybe some1 can add this to our cars

Last edited by miikew; 03-17-2016 at 02:04 AM.
miikew is offline   Reply With Quote
Old 03-17-2016, 02:11 AM   #1043
miikew
Registered User
 
Join Date: Sep 2015
Location: Poland
Posts: 33
My Ride: X3 E83
Pete, how can i migrate from rpib+ to rpi3 ? is this PnP ?
miikew is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-17-2016, 06:48 AM   #1044
PeteAU
Registered User
 
Join Date: Oct 2011
Location: Melbourne
Posts: 541
My Ride: 330i
Quote:
Originally Posted by miikew View Post
Pete, how can i migrate from rpib+ to rpi3 ? is this PnP ?
The openelec web site has different downloads for Pi1 and Pi2/3, so you'd have to reinstall it. Besides that, it's a pretty easy swap.
PeteAU is offline   Reply With Quote
Old 03-17-2016, 08:09 AM   #1045
harmzs
Registered User
 
Join Date: Jun 2014
Location: England, UK
Posts: 99
My Ride: 2003 330ci Clubsport
Quote:
Originally Posted by PeteAU View Post
About the mod on the previous page: https://forum.e46fanatics.com/showthr...3&page=51#1017

Do you reckon you could try something like that, is it within your soldering experience? If I sent you the parts, or show you where to get them off ebay (they cost virtually nothing)?

I looked at the schematic of the Pi's internal audio (used by PiBUS2), compared to PIBUS4 and it's really similar, except these two missing caps. My car doesn't exhibit the loop unfortunately, so somebody else needs to check it. I don't know if it's your answer, maybe 50/50 chance.


* PiBUS4 is basically the same as this, but without C48, C34.
Happy to give it a shot, I'm 75% sure the chap at work can sort it for me if I give him some beer tokens. Probably not economical to send the parts from Australia over to the UK considering the parts are only a couple of GBP at max.

If you do any sort of 'revisions' to the Pibus and need a test mule, I'm happy to split postage costs (here and back) with you to see if works There's gotta be something simple to fix it...hopefully!

Edit: I managed to dig out my old Pibus v1 but I can't get any video/audio out of it, guessing something's probably broken somewhere on the Pi/Pibus.

Last edited by harmzs; 03-17-2016 at 08:11 AM.
harmzs is offline   Reply With Quote
Old 03-17-2016, 12:48 PM   #1046
rockadoodle
Registered User
 
Join Date: Aug 2015
Location: Germany
Posts: 30
My Ride: Z4M Coupe
DIY E46 Media Centre: MP3, videos, Digital Radio, Digital TV?

Hi Guys,

Did anybody got Bluetooth Audio Streaming with openelec and pibus working? As the AirPlay function seems not be working anymore since ios9 and kodi it would be great to stream music from my iPhone to pibus by using Bluetooth. As far as I already understood openelec seems not to be able to stream music via Bluetooth. Maybe someone from you has found a way to get audio streaming up and running and shares his experience. Thanks!

Last edited by rockadoodle; 03-17-2016 at 12:48 PM.
rockadoodle is offline   Reply With Quote
Old 03-17-2016, 12:54 PM   #1047
rockadoodle
Registered User
 
Join Date: Aug 2015
Location: Germany
Posts: 30
My Ride: Z4M Coupe
Quote:
Originally Posted by timanrebel View Post
Is someone interested in a installer script to run the pibus on OSMC instead of OpenElec btw? I can create it based on my changes.

Hi timanrebel,

Your skin looks really nice, great work and thanks for sharing it. Do you know whether OSMC supports streaming music from
the iPhone to the pi via Bluetooth?

I am also interested in the installer script and it would be great if you could share it.

Thank you
rockadoodle is offline   Reply With Quote
Old 03-17-2016, 04:04 PM   #1048
WazKid
Registered User
 
Join Date: Mar 2016
Location: CA
Posts: 24
My Ride: E83
Quote:
Originally Posted by rockadoodle View Post
Hi Guys,

Did anybody got Bluetooth Audio Streaming with openelec and pibus working? As the AirPlay function seems not be working anymore since ios9 and kodi it would be great to stream music from my iPhone to pibus by using Bluetooth. As far as I already understood openelec seems not to be able to stream music via Bluetooth. Maybe someone from you has found a way to get audio streaming up and running and shares his experience. Thanks!
https://github.com/sretlawd/btaudio

I'm waiting for my bluetooth dongle so haven't tried this, but was planning on it. Maybe you'll get it working?
WazKid is offline   Reply With Quote
Old 03-17-2016, 08:45 PM   #1049
rockadoodle
Registered User
 
Join Date: Aug 2015
Location: Germany
Posts: 30
My Ride: Z4M Coupe
Quote:
Originally Posted by WazKid View Post



I'm waiting for my bluetooth dongle so haven't tried this, but was planning on it. Maybe you'll get it working?

Thanks for the hint. I will give a try, but first of all I have to order a Bluetooth dongle. Which one have you ordered?
rockadoodle is offline   Reply With Quote
Old 03-18-2016, 05:35 AM   #1050
PeteAU
Registered User
 
Join Date: Oct 2011
Location: Melbourne
Posts: 541
My Ride: 330i
Quote:
Originally Posted by harmzs View Post
Happy to give it a shot, I'm 75% sure the chap at work can sort it for me if I give him some beer tokens. Probably not economical to send the parts from Australia over to the UK considering the parts are only a couple of GBP at max.
I could send them as a letter, with a $3 stamp. But check that your board actually has those pads on the bottom, because early V4 boards didn't have them yet.

Quote:
Originally Posted by harmzs View Post
If you do any sort of 'revisions' to the Pibus and need a test mule, I'm happy to split postage costs (here and back) with you to see if works There's gotta be something simple to fix it...hopefully!
Not really. Since you mentioned the old Pi1, I just noticed this difference in the audio circuits, so thought it would be worth a shot.

Quote:
Originally Posted by harmzs View Post
Edit: I managed to dig out my old Pibus v1 but I can't get any video/audio out of it, guessing something's probably broken somewhere on the Pi/Pibus.
RCA cable or 3.5mm audio cable missing, or SD card blank?
PeteAU is offline   Reply With Quote
Old 03-18-2016, 01:57 PM   #1051
WazKid
Registered User
 
Join Date: Mar 2016
Location: CA
Posts: 24
My Ride: E83
Quote:
Originally Posted by rockadoodle View Post
Thanks for the hint. I will give a try, but first of all I have to order a Bluetooth dongle. Which one have you ordered?
IOGear GBU521 - Bluetooth 4.0 Micro adaptor
(http://elinux.org/RPi_USB_Bluetooth_adapters)
WazKid is offline   Reply With Quote
Old 03-18-2016, 02:01 PM   #1052
Obioban
Registered User
 
Join Date: Oct 2002
Location: Malvern, PA
Posts: 1,435
My Ride: 05 M3, 01 M5, M3iT
Send a message via AIM to Obioban
Any chance of a program similar to YaV1 that would run on this?

I've been thinking about switching to an Avin, primarily for YaV1. If this could run it instead, I'd much rather keep the stock head unit and go this route.
__________________
-Ian

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
Obioban is offline   Reply With Quote
Old 03-19-2016, 09:57 AM   #1053
WazKid
Registered User
 
Join Date: Mar 2016
Location: CA
Posts: 24
My Ride: E83
Quote:
Originally Posted by WazKid View Post
I'm looking for a metal case which fits both Raspberry Pi 2 B and the Pibus4. Does anyone have a suggestion? What have you guys got?
Bump

How do you guys store it in the car? Any suggested cases?
WazKid is offline   Reply With Quote
Old 03-19-2016, 04:21 PM   #1054
rockadoodle
Registered User
 
Join Date: Aug 2015
Location: Germany
Posts: 30
My Ride: Z4M Coupe
Quote:
Originally Posted by WazKid View Post
Bump



How do you guys store it in the car? Any suggested cases?

I am using this case
http://www.amazon.com/Raspberry-Mode.../dp/B00PH6RF0A

It fits pretty well.
rockadoodle is offline   Reply With Quote
Old 03-22-2016, 12:26 PM   #1055
BMW 740iL NL
Registered User
 
Join Date: Feb 2016
Location: NL
Posts: 53
My Ride: 1998 BMW 740iL
I read OpenElec 7 is released in beta with bluetooth audio support and Airplay update to support audio over Airplay on ios 9.

Anybody tried this beta?

Last edited by BMW 740iL NL; 03-22-2016 at 12:26 PM.
BMW 740iL NL is offline   Reply With Quote
Old 03-24-2016, 09:34 AM   #1056
WazKid
Registered User
 
Join Date: Mar 2016
Location: CA
Posts: 24
My Ride: E83
rockadoodle; Tnx for the tip

BMW 740iL NL; OpenElec 7 sounds interesting. Maybe format a new sd card and try? I will test it as soon as i get the pibus hooked up to the car after easter.

Has anyone got a solution for DAB radio? Would be nice to get DAB radio with the interface in kodi with iex. USB DAB?
- https://github.com/AlbrechtL/rtl_dab...ster/README.md

- http://m.ebay.com/itm/E4000-USB-DVB-...715?nav=SEARCH

Last edited by WazKid; 03-24-2016 at 05:03 PM.
WazKid is offline   Reply With Quote
Old 03-28-2016, 06:12 AM   #1057
BMW 740iL NL
Registered User
 
Join Date: Feb 2016
Location: NL
Posts: 53
My Ride: 1998 BMW 740iL
HELP! I lost sound! My pibus was working perfect but today it started with no sound. I can see in settings it still uses snd_rpi_dac as audio output and with the kodi remote on my iphone app I can see volume is set to max. Everything else is working fine: videos play, I can use the kodi remote, my radio has sound, but pibus on CD-mode is silent.
my setup is pibus v4 on rPi 2 with a BM24 radio

UPDATE: my BM24 radio is ok: checked radio input by hooking up the CDC instead of Pibus and CD audio is ok!

@Pete Can you tell me how I can check Pibus audio?

Last edited by BMW 740iL NL; 03-30-2016 at 09:03 AM.
BMW 740iL NL is offline   Reply With Quote
Old 03-28-2016, 01:24 PM   #1058
Ben1902
Registered User
 
Join Date: Jan 2010
Location: Norway
Posts: 11
My Ride: E83
Yuup

Quote:
Originally Posted by miikew View Post
anyone working on plugin for kodi to read cardata from cheap bluetooth ELM327 module ? maybe some1 can add this to our cars
I am willing to PAY for such solution. Exhaust backpressure, aircharge pressure.. Just a few values to read off will help to detect engine faults before the engine take damage from it.

/Ben
Ben1902 is offline   Reply With Quote
Old 03-29-2016, 02:33 AM   #1059
sk8prom
Registered User
 
Join Date: Mar 2016
Location: Moscow
Posts: 6
My Ride: 330Ci
Hi, everyone))
sorry for my bad English)
why keyboard is`t working on PM3 and BMW2 skin???
what i have to do to fix this problem?))
sk8prom is offline   Reply With Quote
Old 03-29-2016, 09:21 AM   #1060
harmzs
Registered User
 
Join Date: Jun 2014
Location: England, UK
Posts: 99
My Ride: 2003 330ci Clubsport
Quote:
Originally Posted by PeteAU View Post
I could send them as a letter, with a $3 stamp. But check that your board actually has those pads on the bottom, because early V4 boards didn't have them yet.



Not really. Since you mentioned the old Pi1, I just noticed this difference in the audio circuits, so thought it would be worth a shot.



RCA cable or 3.5mm audio cable missing, or SD card blank?
Thanks again Pete, I really appreciate your efforts.

I'll check the Pibus v4 board this evening to see if I've got those two contact points. Fingers crossed it works,

I didn't have much time over Easter to try the V1 board, I think the Pi itself isn't behaving correctly so I'll try and grab a second hand one and give it another shot.
harmzs is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON



All times are GMT -5. The time now is 01:15 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
(c) 1999 - VerticalScope Inc. All rights reserved.