Fuel Station pumped diesel instead of gasoline! - Page 4 - E46Fanatics E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rating: Thread Rating: 4 votes, 5.00 average. Display Modes
Old 07-20-2012, 02:41 PM   #61
jgold47
Registered User
 
Join Date: Sep 2010
Location: Imported from Detroit
Posts: 1,267
My Ride: 2004 X5 3.0
Quote:
Originally Posted by zanga254 View Post
I was on the phone with our MB associate today and he said every mechanic in the shop went to go look at my dad's car and they all smelled diesel. He also saved us a sample of the fuel put in the tank if we wanted to have it lab tested.

I'll be back with more info but I have work soon. Thanks for everything so far guys.
Let me tell you a story.

My wife bought a 2008 saturn vue used from a local dealer. car ran great, no issues till one day she called to tell me it sounded like a diesel and was throwing a code. We took it to the closest GM dealer (under warranty still). Being a car guy, I immediately searched for what the issue might be. I found some vague references to piston ring tolerances, but more on that later.

The dealer calls us back and tells us that lo and behold, a piece of the oil filter disintegrated, got sucked into the engine and starved the engine of oil. The cost to diagnose/repair this (IF it could be repaired) was so high that they wouldnt really tell us and definately not covered under our warranty.

I called the dealer we bought this from (still the original filter) to see what their end would be. they informed me that since this was NAPA filter, to contact napa. I did, and turns out napa was willing to cover our repair IF the filter was truely defective (which it was). However, we had to pay for the repair, and napa would reimburse us.

Now the dealer had a firm price, about 2500. They started to fix it, put everythign back together, but the car was still misfiring. I did some more reasearch and found a guy with the same problem. Turns out this cylender ring issue was the culprit, covered under warranty and fixed the problem. I told this to the dealer, but they kept saying it wasnt it and never could lick the problem. But they got tired of working on it because they had probably already burned through the 2500 they agreed to to fix the car. I couldnt submit any more to NAPA and I wasnt going to pay for it.

this dragged on for a month before they finally gave us the car back and said, not to bring it back in.

The long and short of that story is that a dealer (especially a dealer not an indy) will tell you anything you want to hear when they know they are getting a cash repair. The way that they left it up to you to VERIFY it was diesel completely absolves them. They get paid regardless, and if you keep having problems, they will keep fixing them for you and telling you to try and get reimbursed for it.

Good luck man, regardless of the fact I think your trolling, this still sucks. I know how bad it sucked for us and I was only out of pocket $75 for the alignment that NAPA wouldnt cover.
__________________
Religion, Politics, and which oil is the best to use. Three things never to be discussed in polite company...

my about me link
https://forum.e46fanatics.com/showthread.php?t=791566

jgold47 is offline   Reply With Quote
Old 07-20-2012, 02:41 PM   #62
WALDE_BORA
Registered User
 
Join Date: Jul 2012
Location: San German, PR
Posts: 54
My Ride: 99' 323i, 99' JETTA
Quote:
Originally Posted by NJFF26 View Post
I think its been beat enough that is wasn't a diesel pump, it then switched to the gas is contaminated with diesel.
me not reading the whole thead ... my bad...
WALDE_BORA is offline   Reply With Quote
Old 07-20-2012, 04:15 PM   #63
Mr_325
Registered User
 
Join Date: Sep 2008
Location: Chwk, BC
Posts: 842
My Ride: 2007 X5 3.0Si
i did this in my mustang (my first car)
PITA cleaning it all out
i'm with everyone else though.. how did she get it in ur tank? they have something on them that doesn't let them violate our cars
Mr_325 is offline   Reply With Quote
Old 07-22-2012, 08:34 PM   #64
zanga254
Registered User
 
Join Date: Dec 2011
Location: NOVA and Philly
Posts: 68
My Ride: 2002 325xi ZPP
Quote:
Originally Posted by jgold47 View Post
Good luck man, regardless of the fact I think your trolling, this still sucks. I know how bad it sucked for us and I was only out of pocket $75 for the alignment that NAPA wouldnt cover.
Honestly we're all in this forum for help from fellow e46fanatics. I don't know why anyone would troll here.
Attached Thumbnails
Click image for larger version

Name:	c280 diesel.jpg
Views:	98
Size:	104.4 KB
ID:	461763  
__________________
Quote:
Originally Posted by djlinux64 View Post
I am content with cruising at only 130 mph.
zanga254 is offline   Reply With Quote
Old 07-23-2012, 01:40 PM   #65
Lionelski
Registered User
 
Join Date: Jun 2004
Location: Long Island, NY
Posts: 1,194
My Ride: 325CIc
Quote:
Originally Posted by zanga254 View Post
Our friend said to present a formal notice that they should keep security footage from that day, since some tapes are deleted within a couple days. That way if they delete it after signing the notice, it's a pretty simple win from there.
Forget the security tape.
No reason for them to spend the time showing it to you.
Formal notice from you is nonsense and would be useless. A court order would be different but that ain't gonna happen either, especially not this quickly.

You have no evidence that it even was this gas station.
If this really happened, sorry to tell you, but you are out of luck
__________________
'Ski
www.WarrenvilleRailroad.com
2001 325ci Convertible - Titanium Silver

Sport Package, Premium Package
Racing Dynamics Strut Tower Brace
Conforti Shark Injector, Conforti CAI
Interior: Leather, Euro Tray, M3 Dead Pedal
Lionelski is offline   Reply With Quote
Old 07-23-2012, 01:47 PM   #66
jdstrickland
Registered User
 
Join Date: Apr 2010
Location: Murrieta, CA
Posts: 9,776
My Ride: '94 325iC & '00 323i
The MAF did not get burned out due to the wrong fuel. It is false for the fuel to be the reason for the MAF failure. The MAF might have been bad, but the fuel did not break it. The MAF and the fuel are never even in the same room together, and the airflow through the MAF would have to completely reverse while fuel was pumping. Fuel would have to move from the cylinders backwards through the intake tract in order to contaminate the MAF. This alone would be a catastrophic event that would mean there are other problems with the motor long before the wrong fuel came along.
jdstrickland is offline   Reply With Quote
Reply

Tags
diesel, gasoline, mercedes, wrong

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON



All times are GMT -5. The time now is 11:14 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
(c) 1999 - VerticalScope Inc. All rights reserved.