[MS4X] Dev Group Flasher For MS42 & MS43 - Page 5 - E46Fanatics E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Go Back   E46Fanatics > Tuning & Tech > Driveline, Engine & DME Tuning

Driveline, Engine & DME Tuning
Talk about driveline improvements, NA tuning and DME tuning your E46 BMW here. This includes diffs, intakes, exhausts, chips, software and OBD tuning.

Reply
 
Thread Tools Search this Thread Rating: Thread Rating: 2 votes, 5.00 average. Display Modes
Old 03-22-2020, 10:21 AM   #81
jds2726
Registered User
 
Join Date: Dec 2017
Location: Baltimore, MD
Posts: 85
My Ride: 2003 325Ci Cabrio
Transmission: ZF 5HP-19
sda2 already explained this. That being said I run this software on a computer used for tuning only, so no valuable information anyways. I've even baited it with a few inconsequential passwords anyways and have not seen any intrusions. I wouldn't worry about it.

Quote:
Originally Posted by sda2 View Post
It's not a virus, the tool is protected against reverse engineering. This kind of protection is also often used by malware authors, that's why you get the alarm.



There was an issue with the MS42 fullflash inside the software that will be fixed in the next version.

Fixed version will come soon, stay tuned for release here.



I do not have any problems with activation, also running 1903 on all my PCs.

Are you running inside VM?
jds2726 is offline   Reply With Quote
Old 03-22-2020, 11:53 AM   #82
MarkD_M5
Registered User
 
Join Date: May 2010
Location: Toronto
Posts: 17
My Ride: various BMW's
Thanks,

I had not read the pages which mentioned that earlier, and then saw it after posting. I guess I'll try it out.

I'm not sure why there is such an interest in protection against reverse engineering of such a tool.

Last edited by MarkD_M5; 03-22-2020 at 11:54 AM.
MarkD_M5 is offline   Reply With Quote
Old 03-22-2020, 01:02 PM   #83
TerraPhantm
Registered User
 
Join Date: Feb 2008
Location: Philadelphia
Posts: 7,951
My Ride: M3
Quote:
Originally Posted by MarkD_M5 View Post
Thanks,

I had not read the pages which mentioned that earlier, and then saw it after posting. I guess I'll try it out.

I'm not sure why there is such an interest in protection against reverse engineering of such a tool.
I guess their goal is to prevent someone else repackaging the tool in some paid application, but I do think they went over the top. The online licensing with frequent server failures make it a pain to use. And the ridiculous obfuscation resulting in constan antivirus alerts is a pain too. Contrast that with something like MSSFlasher where despite being a paid tool, it's deliberately stupid easy to disassemble and do what you want with it.
__________________

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Last edited by TerraPhantm; 03-22-2020 at 01:03 PM.
TerraPhantm is offline   Reply With Quote
Old 03-22-2020, 01:20 PM   #84
jds2726
Registered User
 
Join Date: Dec 2017
Location: Baltimore, MD
Posts: 85
My Ride: 2003 325Ci Cabrio
Transmission: ZF 5HP-19
Quote:
Originally Posted by TerraPhantm View Post
I guess their goal is to prevent someone else repackaging the tool in some paid application, but I do think they went over the top. The online licensing with frequent server failures make it a pain to use. And the ridiculous obfuscation resulting in constan antivirus alerts is a pain too. Contrast that with something like MSSFlasher where despite being a paid tool, it's deliberately stupid easy to disassemble and do what you want with it.
Imo it's not that terrible. I just activated once and haven't had any problems with activation since. Just turn off windows defender and forget about it until next year. I did have problems with Windows 7 32-bit where it wouldn't activate. I just moved to 64-bit and went on my merry way. Gives me the ability to add some extra ram anyways.

After all it's free, I'm willing to jump through a few hoops for that. Might try cracking it for fun later though, given the open invite
jds2726 is offline   Reply With Quote
Old 03-22-2020, 01:25 PM   #85
jds2726
Registered User
 
Join Date: Dec 2017
Location: Baltimore, MD
Posts: 85
My Ride: 2003 325Ci Cabrio
Transmission: ZF 5HP-19
Quote:
Originally Posted by jds2726 View Post
I'm having a problem with the new ms4x flasher. When reading the 512kb file it quits out about half way through and say lost connection to ECU. I can read the 64k file with now problems. Almost seems like the ecu is timing out. I'm in the run position with engine off. Everything works perfectly with galletto, MSS5X and JMGarage. Haven't tried write yet.
Oddly enough, the flasher works perfectly with the ECU on the bench. Any reason it would have these problems while in the car?
jds2726 is offline   Reply With Quote
Old 03-25-2020, 08:32 AM   #86
Madhouse
Registered User
 
Join Date: Mar 2020
Location: Asturias
Posts: 67
My Ride: BMW 330CI replicaM3
I have the same problem, when loading total reading it closes me and gives communication error, with windows 7 sp1 32bits. Upgrading to sp2 would it be fixed?
__________________

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
Madhouse is offline   Reply With Quote
Old 03-25-2020, 09:00 AM   #87
Madhouse
Registered User
 
Join Date: Mar 2020
Location: Asturias
Posts: 67
My Ride: BMW 330CI replicaM3
I managed to do partial 64kb read, but I need 512kb read for tunerpro.
__________________

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
Madhouse is offline   Reply With Quote
Old 03-29-2020, 09:18 AM   #88
jds2726
Registered User
 
Join Date: Dec 2017
Location: Baltimore, MD
Posts: 85
My Ride: 2003 325Ci Cabrio
Transmission: ZF 5HP-19
Madhouse, the only way I have managed to do full reads/writes with no interruption is with a bench flash setup. Maybe try charging the car while reading?
jds2726 is offline   Reply With Quote
Old 03-29-2020, 10:17 AM   #89
Madhouse
Registered User
 
Join Date: Mar 2020
Location: Asturias
Posts: 67
My Ride: BMW 330CI replicaM3
I managed to do a full read with mss5x chipster, does it have to be done with ms4 flasher to work with tunerpro?
__________________

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
Madhouse is offline   Reply With Quote
Old 03-29-2020, 01:50 PM   #90
jds2726
Registered User
 
Join Date: Dec 2017
Location: Baltimore, MD
Posts: 85
My Ride: 2003 325Ci Cabrio
Transmission: ZF 5HP-19
No, just correct your checksums before flashing. If your using the patch list don't use mss5x, it has a problem when flashing the program section
jds2726 is offline   Reply With Quote
Old 03-29-2020, 02:18 PM   #91
Madhouse
Registered User
 
Join Date: Mar 2020
Location: Asturias
Posts: 67
My Ride: BMW 330CI replicaM3
So I will put a battery charger and try to do full read with ms4x. I have some fear then to rewrite the dme, because everything works well.
__________________

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
Madhouse is offline   Reply With Quote
Old 03-30-2020, 03:21 PM   #92
Madhouse
Registered User
 
Join Date: Mar 2020
Location: Asturias
Posts: 67
My Ride: BMW 330CI replicaM3
I have fixed read checksum after applying cluster patch ms430066 and it modifies these values ***8203;***8203;for me. This right ??

00073FE0.
00074840
00074850
00078510
00078520
Attached Thumbnails
Click image for larger version

Name:	DSC_0355_1585599446327.jpg
Views:	24
Size:	107.6 KB
ID:	796841   Click image for larger version

Name:	DSC_0356_1585599542712.jpg
Views:	20
Size:	99.5 KB
ID:	796843   Click image for larger version

Name:	DSC_0357_1585599608361.jpg
Views:	18
Size:	103.4 KB
ID:	796845  
__________________

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
Madhouse is offline   Reply With Quote
Old 03-30-2020, 04:14 PM   #93
Madhouse
Registered User
 
Join Date: Mar 2020
Location: Asturias
Posts: 67
My Ride: BMW 330CI replicaM3
Finally, with which program do I write the new values ***8203;***8203;in the DME?
__________________

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
Madhouse is offline   Reply With Quote
Old 03-31-2020, 08:57 AM   #94
Madhouse
Registered User
 
Join Date: Mar 2020
Location: Asturias
Posts: 67
My Ride: BMW 330CI replicaM3
In the end I managed to do a total 512kb reading with ms4flasher. But when using it with tunerpro patches it gives me checksum error with checksum.
Attached Thumbnails
Click image for larger version

Name:	DSC_0362_1585662998265.jpg
Views:	24
Size:	78.6 KB
ID:	796885  
__________________

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
Madhouse is offline   Reply With Quote
Old 03-31-2020, 09:13 AM   #95
Madhouse
Registered User
 
Join Date: Mar 2020
Location: Asturias
Posts: 67
My Ride: BMW 330CI replicaM3
Without being able to do a checksum, modify these values:
Now what reading I have done should I proceed?
Attached Thumbnails
Click image for larger version

Name:	DSC_0358_1585663633668.jpg
Views:	22
Size:	114.7 KB
ID:	796889   Click image for larger version

Name:	DSC_0359_1585663700251.jpg
Views:	19
Size:	107.3 KB
ID:	796891   Click image for larger version

Name:	DSC_0360_1585663756931.jpg
Views:	17
Size:	115.9 KB
ID:	796893   Click image for larger version

Name:	DSC_0361_1585663959241.jpg
Views:	18
Size:	110.4 KB
ID:	796895  

__________________

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
Madhouse is offline   Reply With Quote
Old 03-31-2020, 02:19 PM   #96
Madhouse
Registered User
 
Join Date: Mar 2020
Location: Asturias
Posts: 67
My Ride: BMW 330CI replicaM3
Is it correct or am I wrong???
__________________

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
Madhouse is offline   Reply With Quote
Old 04-02-2020, 08:25 AM   #97
Madhouse
Registered User
 
Join Date: Mar 2020
Location: Asturias
Posts: 67
My Ride: BMW 330CI replicaM3
Reading 512kb with ms4x flasher does not allow checksum. I don't know how to continue? Can anybody help me ?
__________________

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
Madhouse is offline   Reply With Quote
Old 04-08-2020, 11:41 PM   #98
CarbonZHP
Because Race...Convertible?
 
CarbonZHP's Avatar
 
Join Date: Jun 2013
Location: EAS
Posts: 2,921
My Ride: goes choo choo
Year: 2004
Model: 330Cic ZHP
Transmission: AT->5MT->6MT
Bump, is the activation site down?
__________________

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
Original Car: Silver Grey on Grey, A/T (1 of 186)
As it sits: Silver Grey on Black, M/T (1 of 51)
Instagram: @CarbonZHP
CarbonZHP is offline   Reply With Quote
Old 04-09-2020, 07:59 AM   #99
sda2
Registered User
 
Join Date: Feb 2015
Location: Germany
Posts: 475
My Ride: BMW E46 330i Touring
Yes it was, working again now.

Please don't trash the thread with mss5x topic or multiple offtopic posts, thank you.
__________________
..:: Visit
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
- the ultimate Siemens MS wiki ::..
sda2 is offline   Reply With Quote
Old 04-15-2020, 12:27 PM   #100
epborden
Registered User
 
Join Date: Mar 2020
Posts: 12
Can we run this tool in a Windows 10 VM as long as we connect the cable to the VM?
epborden is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Censor is OFF



All times are GMT -5. The time now is 03:33 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
(c) 1999 - VerticalScope Inc. All rights reserved.