[SOLVED] Crank, but won't start (after engine swap) - E46Fanatics E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 05-23-2020, 10:05 AM   #1
mega_stihl
Registered User
 
Join Date: Dec 2017
Location: Belgium
Posts: 794
My Ride: E46 & E32
[SOLVED] Crank, but won't start (after engine swap)

Swap is done. M54B30 is in the car, everything is connected. Car cranks, but won't start. Not even one "poof" or anything.

Well, not everything is connected, but the important things needed to start the car, are. The MAF is not yet connected, which does not seem important, as many disconnect it to diagnose if it's working or not, and simply drive off without one. LPG injectors are not connected, but all (vacuum) holes/tubes have been shut off. Primary OČ sensors are connected. There is fuel pressure.

When I hit the throttle pedal with ignition on, I don't hear the throttle valve opening/closing. Is this normal?

Is there anything I can check in INPA? I'm asking, as I find INPA one of the most confusing software used to diagnose a car ...

Also: DME and wiring harness are the same as before, so for the electronics, nothing should have changed.
__________________

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

E46 320Ci FL swapped to 330Ci
Bilstein B12 - H&R sways

Last edited by mega_stihl; 05-23-2020 at 11:07 AM.
mega_stihl is offline   Reply With Quote
Old 05-23-2020, 10:22 AM   #2
infoboy
Registered User
 
Join Date: Aug 2018
Location: lebanon
Posts: 378
My Ride: 325ci
If your car was 325/320 before and you still running the 325/320 software on the ecu sometimes it wont start with m54b30 injectors like in my case it didnt start so i did reuse the b25 injector temporary and started the car.next day b30 software was uploaded on the car and i did instal the b30 injectors again and everything was fine.

Sent from my SM-J415F using Tapatalk

Last edited by infoboy; 05-23-2020 at 10:23 AM.
infoboy is offline   Reply With Quote
Old 05-23-2020, 11:07 AM   #3
mega_stihl
Registered User
 
Join Date: Dec 2017
Location: Belgium
Posts: 794
My Ride: E46 & E32
SOLVED!

I forgot that the wiring of the fuel injectors goes through the LPG module, as the injectors need to be shut off once the car runs on LPG. I didn't connect the LPG module yet. Connected it, starts and runs fine! Still some issues I might have to look after, like alternator light that stays on for some reason.
__________________

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

E46 320Ci FL swapped to 330Ci
Bilstein B12 - H&R sways
mega_stihl is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON



All times are GMT -5. The time now is 04:03 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
(c) 1999 - VerticalScope Inc. All rights reserved.